Wandboard Quad LVDS

Discussion of your EDM baseboard, your add-on boards or other peripherals for your wandboard.

Wandboard Quad LVDS

Postby Andreas » Fri May 13, 2016 5:32 am

Hello everyone!!!

I am trying to get a LVDS Display working on my Wandboard Quad. Its an EDT et0700g1dm6 (7inch WVGA LVDS Display).
Right now i am using the Ubuntu 14.04 Image from the download section.
I wired the Display to the expansion header according to the usergide, but the display only lights up, it doesen't show anything.
Do I need to make any changes to the Kernel boot parameters to get this to work? Or maybe the Devide Tree? Anything else?

Thank you for the help.
Andreas
 
Posts: 2
Joined: Fri May 13, 2016 5:19 am

Re: Wandboard Quad LVDS

Postby nevmair » Mon May 16, 2016 3:22 am

To specify a LVD display add something like this to the kernel command line

video=mxcfb0:dev=ldb,800x480M@60,if=RGB666

Our display is also 18 bit 800x480, not sure about the other parameters.

We also had to modify the dtb file to correctly work.
By default, the dtb file has the LVDS disabled ( in this file arch/arm/boot/dts/imx6qdl.dtsi) and the timing was wrong for our display.

Hope this helps

Neville
nevmair
 
Posts: 43
Joined: Mon Feb 16, 2015 3:42 pm

Re: Wandboard Quad LVDS

Postby Andreas » Wed May 18, 2016 8:46 am

Can you please post your .dts file that contains the nodes for ldb, lvds-channel and display-timings?

This is what i have:
Code: Select all
         ldb: ldb@020e0008 {
            #address-cells = <1>;
            #size-cells = <0>;
            gpr = <&gpr>;
            ststus = "okay";

            lvds-channel@0 {
               reg = <0>;
               crtcs = <&ipu1 0>;
               crtc = "ipu-di0";
               primary = "teue";
                           fsl,data-mapping = "spwg";
                           fsl,data-width = <18>;/*oder 24*/
               status = "okay";
                           display-timings {
                                   native-mode = <&timing0>;
                              timing0: 800x400 {
                                      /* 800x480 */
                                      clock-frequency = <33260000>;
                                      hactive = <800>;
                                      hfront-porch = <64>;
                                      hback-porch = <64>;
                                      hsync-len = <128>;

                                      vactive = <480>;
                                      vback-porch = <21>;
                                      vfront-porch = <21>;
                                      vsync-len = <2>;

                                      hsync-active = <0>;
                     vsync-active = <0>;
                              };
                           };
            };

mxcfb2: fb@1 {
                compatible = "fsl,mxc_sdc_fb";
                disp_dev = "ldb";
                interface_pix_fmt = "RGB666";
      mode_str ="LDB_WVGA";
                default_bpp = <24>;
                int_clk = <0>;
                late_init = <0>;
                status = "okay";
};
Andreas
 
Posts: 2
Joined: Fri May 13, 2016 5:19 am

Re: Wandboard Quad LVDS

Postby nevmair » Thu May 19, 2016 1:44 pm

I'm not sure in what context you are working.
My changes were made in linux-wandboard_imx_3.10.53_1.1.0_ga branch

This was added in imx6dl-wandboard.dts
Code: Select all
&ldb {
   lvds-channel@0 {
      crtc = "ipu1-di1";
      status = "okay";

   };
};

The status was set to okay.

We needed to modify imx6qdl-wandboard.dtsi
Code: Select all
&ldb {
   status = "okay";
   lvds-channel@0 {
      fsl,data-mapping = "spwg";
      fsl,data-width = <18>;
      primary;
      status = "okay";

      display-timings {
         native-mode = <&timing0>;
         timing0: hj070na {
            clock-frequency = <30066000>;
            hactive = <800>;
            vactive = <480>;
            hback-porch = <90>;
            hfront-porch = <120>;
            vback-porch = <1>;
            vfront-porch = <1>;
            hsync-len = <100>;
            vsync-len = <33>;
         };
      };
   };
};

These 3 lines were changed for our display to look correct.
fsl,data-width = <18>;
clock-frequency = <30066000>;
hactive = <800>;
vactive = <480>;

And this section was modified to set the default_bpp = <18>
Code: Select all
        mxcfb2: fb@1 {
                compatible = "fsl,mxc_sdc_fb";
                disp_dev = "ldb";
                interface_pix_fmt = "RGB666";
                default_bpp = <18>;
                int_clk = <0>;
                late_init = <0>;
                status = "disabled";
        };


Neville
nevmair
 
Posts: 43
Joined: Mon Feb 16, 2015 3:42 pm


Return to Hardware and peripherals

Who is online

Users browsing this forum: No registered users and 10 guests

cron