Page 1 of 2

MIPI-DSI display testing

PostPosted: Sat Jun 14, 2014 1:36 pm
by jcsistemas2001
Hello,
I'm trying to use a Wandboard Quad using a DSI display (as show the attached picture). Using the kernel 3.0.35 and Android 4.2.2, I did two test:
- TEST 1: using a HDMI monitor, everything is OK.
- TEST 2: using a dsi display, the image is black. The display is setup according with the driver specification (in DSI command mode) with success. The signals in the display connector seem OK. The CLK in command and video mode are according with the display specs.
If somebody have some idea, don't hesitate to share.
Thanks for any suggestions.
JC

Re: MIPI-DSI display testing

PostPosted: Mon Jun 16, 2014 3:34 am
by Tapani
Just to avoid te obvious:
- Have you checked that backlight is on?
- Are all the driving voltages to your display correct (measure)?

Also, I think this is not a topic for the "getting started" section... :-) It is beyound that.

Re: MIPI-DSI display testing

PostPosted: Mon Jun 16, 2014 11:11 am
by jcsistemas2001
You don't. Nothing is obvious. You can ask everything.
- Backlight is already fix (not controlled by HOST).
- The RESET pin is OK and tested
- The D0 pin is OK, because the command mode communication is through this differential channel
- The D1 and CLK seem OK, also with data
Please, can you help me to move this topic to the adequate forum?
Thanks

Re: MIPI-DSI display testing

PostPosted: Mon Jun 16, 2014 1:11 pm
by jcsistemas2001
Here a little video showing the display with the described issue:
https://www.youtube.com/watch?v=s2xipjNhjcs

Re: MIPI-DSI display testing

PostPosted: Tue Jun 17, 2014 11:51 am
by JayminD
go to below link's pdf :

http://kr.tmsinc.co.kr/media/uploads/do ... 9b8tjv.pdf

may be helpful.

regards

Re: MIPI-DSI display testing

PostPosted: Wed Jun 18, 2014 8:24 am
by jcsistemas2001
Hi JayminD,
Thanks for the reference.
I would like to have these test equipment :)
Regards
JC

Re: MIPI-DSI display testing

PostPosted: Thu Jun 19, 2014 4:28 am
by Tapani
jcsistemas2001 wrote:You don't. Nothing is obvious. You can ask everything.
- Backlight is already fix (not controlled by HOST).
- The RESET pin is OK and tested
- The D0 pin is OK, because the command mode communication is through this differential channel
- The D1 and CLK seem OK, also with data
Please, can you help me to move this topic to the adequate forum?
Thanks

Well, this is beyond me. I might move the topic to the hardware forum when I get the time. Otherwise it stays here :D

Anyway, assuming voltages are ok just because you can talk to a MIPI display is not enough.
The only MIPI display I have experience of had exactly the same symptoms (that was on a TI board).

We could talk to the display, but all it showed was black. In the end (after a few days of frustration) it turned out to be one of the driving voltages was too low.

Good luck!

Re: MIPI-DSI display testing

PostPosted: Thu Jun 19, 2014 7:08 am
by JayminD
jcsistemas2001 wrote:Hi JayminD,
Thanks for the reference.
JC


Thanks for it... mention not...

Best luck.

regards

Re: MIPI-DSI display testing

PostPosted: Wed Jun 25, 2014 5:19 am
by jcsistemas2001
Thanks guys.
I just figure out the problem. I need a few additional setup commands that was not listed in the controller datasheet (impossible to know!)
The attached image show the result.
However and after testing different timing specs, I still get the image as show at: https://www.youtube.com/watch?v=qDsc3PZG0Dk, In some case, worst.
I already try different connection boards to warranty the proper signal (eliminating additional parasitic resistance and capacitors).
Thanks for any additional suggestions.
JC

youtvplayer

PostPosted: Thu Jul 06, 2017 4:36 am
by Michelle108
the Google play shop has actually been claimed to be phony youtvplayer The app increases up as a social media system. Make friends.