Page 1 of 1

WB Solo won't boot

PostPosted: Fri Oct 14, 2016 9:29 am
by toto42
Hi,

I recently purchased a WB solo and I can't manage to make it boot. The first time I tried with the provided Android image, it worked. However, after I tried to reboot, I got nothing. Since then I didn't manage to make it work. To be more precise, the light turns green and doesn't blink, I get nothing on the screen, and no output on the serial port.
I checked the troubleshooting pages on the wiki and on this forum and found no easy answer.
Also, I purchased a second board and the problem is the same, it didn't boot even once (I also tried with the Ubuntu image).

I have no idea about what can be wrong at the moment, and any hint would be helpful.
Thanks in advance.

EDIT: I don't know if this helps: when I try the usb otg, lsusb tells me that one of the boards is in "RecoveryMode"

Re: WB Solo won't boot

PostPosted: Thu Oct 20, 2016 3:59 am
by Tapani
The "recoverymode" part just means that the board was not able to boot from the SD card.

Also, I find it very unlikely that you somehow have two bad boards. What SD cards are you using? Tried another SD card (sometimes cards can go bad)?

Re: WB Solo won't boot

PostPosted: Fri Oct 21, 2016 8:57 pm
by ClayMontgomery
If u-boot does not run, I would try flashing u-boot onto the card again with something like this:

sudo dd if=u-boot-wandboard-quad.imx of=/dev/sdd bs=512 seek=2

This assumes a WB Quad and that card is mounted on sdd.

You should also try a Yocto or Ubuntu image because they are simpler (less partitions)

Regards, Clay

Re: WB Solo won't boot

PostPosted: Thu Nov 03, 2016 1:03 pm
by toto42
Thank you guys for your answers.

@Tapani: I tried with new SD cards (never been used before), it still does not help. I also tried with various images: Android, Ubuntu, Yocto, etc., still no result. I also checked and my SD cards work perfectly fine with other boards (Rpi for example).

@ClayMontgomery: thanks for the idea.I also tried that (with Ubuntu and Yocto images), and the problem still remains :(

At that point, after several weeks of trying for nothing, I still have no clue about what is wrong with those boards, and I am simply going to send them back and to switch to boards from an other manufacturer.

Re: WB Solo won't boot

PostPosted: Thu Nov 03, 2016 5:19 pm
by ClayMontgomery
Are you sure you are using the right card slot?

Look at the first photo on this page:

http://montgomery1.com/deployment/

Regards, Clay

Re: WB Solo won't boot

PostPosted: Thu Nov 03, 2016 7:39 pm
by toto42
Thanks for the advice, but:
i) as I said before, I had android boot once, so I picked the correct slot
ii) I checked the troubleshooting page before posting here, so I think (and hope) that I tried all the easy fixes already
iii) just in case, I triplechecked after reading your message, but, still, I picked the correct slot and nothing happens :(

But thanks for the answer anyway.

Re: WB Solo won't boot

PostPosted: Mon Mar 06, 2017 9:02 pm
by Cypis
Any progress, toto42 ?


I have similar problem -

I have WB Dual,
and tried to boot with Android and Ubuntu images.


SD card written, inserted in right slot,
HDMI connected (tried with both monitor and projector),
power connected,

green LEDs (one on IO board, one on CPU board) light up,
CPU gets a little warm, and.... nothing.



Connected with miniUSB cable via USB OTG to Win7 machine I got "Unknown device" (instead of "Freescale Semiconductor" as described in http://wiki.wandboard.org/index.php/Tro ... won't_boot )


Any ideas ?

Re: WB Solo won't boot

PostPosted: Mon Mar 06, 2017 9:14 pm
by ClayMontgomery
The OTG connector is used for the Android debug console, but not during the Linux kernel boot or for u-boot.

You need to connect a StarTech cable to the DB-9 debug port.

http://montgomery1.com/product/startech ... ole-cable/

You might also try reflashing u-boot with something like:
sudo dd if=u-boot-quad.imx of=/dev/sdd bs=512 seek=2

Regards, Clay

Re: WB Solo won't boot

PostPosted: Fri Mar 10, 2017 11:51 am
by Tapani
As ClayMontgomery said (thanks btw!),

can you try a serial console cable as well?

Also have you tried using a different SD card? Sometimes failing SD cards can refuse to boot (but still be readable on other devices).

The fact that you get an "Unknown device" in Windows might mean that *windows* does not recognize the Freescale device.
If you have Linux computer, lsusb should list the Freescale device.