Compiling u-boot fails...

You have a problem with your Wandboard and want to ask the community for help.

Compiling u-boot fails...

Postby queen-shit » Tue May 10, 2016 6:25 pm

How to deal with this
Code: Select all
queen-shit@adsubia:~/Entwicklung/Wandboard/bootloader/denx/u-boot$ sudo make wandboard_config
#
# configuration written to .config
#
queen-shit@adsubia:~/Entwicklung/Wandboard/bootloader/denx/u-boot$ sudo make
scripts/kconfig/conf  --silentoldconfig Kconfig
  CHK     include/config.h
  GEN     include/autoconf.mk
  GEN     include/autoconf.mk.dep
  GEN     spl/include/autoconf.mk
  CHK     include/config/uboot.release
  CHK     include/generated/version_autogenerated.h
  UPD     include/generated/version_autogenerated.h
  CHK     include/generated/timestamp_autogenerated.h
  UPD     include/generated/timestamp_autogenerated.h
  CC      lib/asm-offsets.s
lib/asm-offsets.c:1:0: error: bad value (armv5) for -march= switch
 /*
 ^
Kbuild:43: die Regel für Ziel „lib/asm-offsets.s“ scheiterte
make[1]: *** [lib/asm-offsets.s] Fehler 1
Makefile:1275: die Regel für Ziel „prepare0“ scheiterte
make: *** [prepare0] Fehler 2


Is there any recent tutorial how to build u-boot for wandboard quad from sources or even better a source for precompiled images?
queen-shit
 
Posts: 6
Joined: Thu Dec 11, 2014 4:00 pm

Re: Compiling u-boot fails...

Postby queen-shit » Tue May 10, 2016 6:29 pm

Would be glad if anybody could upload me a precompiled image for wandboard quad matching with Kernel 4.5.3-armv7-x2...
queen-shit
 
Posts: 6
Joined: Thu Dec 11, 2014 4:00 pm

Re: Compiling u-boot fails...

Postby Tapani » Wed May 18, 2016 12:43 pm

Your problem appears to be here:
error: bad value (armv5) for -march= switch


Seems your compiler cannot create arm executables. Are you sure you are using a cross compiler?
Tapani
Site Admin
 
Posts: 682
Joined: Tue Aug 27, 2013 8:32 am


Return to Getting started

Who is online

Users browsing this forum: No registered users and 3 guests