Getting Started - Building everything

You have a problem with your Wandboard and want to ask the community for help.

Getting Started - Building everything

Postby jmerkle@amltd.com » Mon Aug 03, 2015 3:47 pm

I'm relatively new to the Wandboard and to embedded Linux (still reading, learning, and trying things out.)
The Android 5.0, Lollipop, Uboot, and Linux Kernel are working great on my board. (The getting started guide to create the SD-card worked well.) Thank you!

I'm attempting to locate each of the source trees to download / install to rebuild each of the elements that are currently running on my board (Uboot, Kernel, Android).
The problem is many of the getting started guides associated with Wandboard / Android, are rather old and target Android 4.4. Is there a "Getting Started Building Uboot/Kernel/Android 5 for Wandboard" document / web page around? So far, I have a virtual Ubuntu 14.04.2 LTS build environment, and I've used GIT to bring in the Android and Uboot sources, but none of the documents / web pages I'm reading line up with files contained within the source trees that I've downloaded.

Stating with Uboot, I'm reading the following doc: http://git.denx.de/?p=u-boot.git;a=blob ... a9;hb=HEAD
It describes using the "wandboard_quad_config" configuration file. That doesn't exist in the sources that I downloaded. I have "wandboard_defconfig", but no "wandboard_quad_config".

When I look at the different GIT trees associated with Android sources, the dates involved are about two years old.

I found the following document: http://wiki.wandboard.org/Android_Compi ... al_Machine. It's a wonderful document, but it's targeting Android 4.3.

Could I get a hand updating this document for Android 5.0, and maybe using Ubuntu 14.04 LTS???

Thank you for your help.

Jim
jmerkle@amltd.com
 
Posts: 1
Joined: Mon Aug 03, 2015 3:18 pm

Re: Getting Started - Building everything

Postby vpeter » Mon Aug 03, 2015 6:04 pm

jmerkle@amltd.com wrote:Stating with Uboot, I'm reading the following doc: http://git.denx.de/?p=u-boot.git;a=blob ... a9;hb=HEAD
It describes using the "wandboard_quad_config" configuration file. That doesn't exist in the sources that I downloaded. I have "wandboard_defconfig", but no "wandboard_quad_config".
I don't know how did you get this link but I see this Readme: http://git.denx.de/?p=u-boot.git;a=blob ... d792fc4730

U-boot for Wandboard is now using SPL.
vpeter
 
Posts: 78
Joined: Wed Dec 24, 2014 7:44 am

Re: Getting Started - Building everything

Postby paddy » Thu Sep 10, 2015 3:05 am

Hi
Refereeing to link below, I am unable to get many of links given in web page.
ex: http://www.wandboard.org/images/downloa ... dev_vm.zip

Link which is not working!
http://wiki.wandboard.org/index.php/And ... al_Machine

it says with warning that link moved to some other place,

request you kindly update page
http://wiki.wandboard.org/index.php/And ... al_Machine


Regards
Paddy
paddy
 
Posts: 8
Joined: Sat Jan 11, 2014 12:19 pm

Re: Getting Started - Building everything

Postby vpeter » Thu Sep 10, 2015 8:16 am

vpeter
 
Posts: 78
Joined: Wed Dec 24, 2014 7:44 am


Return to Getting started

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 18 guests