OpenELEC

XBMC subforum

Re: OpenELEC

Postby kk31 » Sat Aug 15, 2015 3:50 pm

Hi,

i've check with OpenELEC-imx6.arm-6.0-devel-20150618185638-r21049-g2018d81-wandboard.img on my WB dual,
everything works very well!
Plays videos in 1080p, mp3 music, live tv...
One issue, it can not play video or live tv with spdif passthrough, no dd5.1 or dts is working.
I've double checked the config options in kodi (same as on my rb pi2), no success
Any suggestion?

Best regards,
Kevin
kk31
 
Posts: 2
Joined: Sat Aug 15, 2015 3:35 pm

Re: OpenELEC

Postby XoD » Fri Aug 21, 2015 11:57 am

Hello, sorry all for the respond delay and thank you for testing.

@Lt.Cmdr.Ivan: sorry it's seems than the kernel version used for imx6 project (base Linux v3.14 modified for cuboxi) doesn't support Wandboard quad revb1.
=> The kernel used don't have the dts for Wandboard quad revb1
I don't know what would be the best way to solve this issue, backport change from newer kernel to currently used, or tried to used a more recent kernel.

@kk31: no idea.

I have build a recent version of image for Wandboard (with a recent u-boot-imx, 2015-07-rc3_156598a)
The file should be available here : http://www.xoddark.com/Public/openelec/ ... -20150821/
XoD
 
Posts: 43
Joined: Thu May 29, 2014 12:52 pm

Re: OpenELEC

Postby vpeter » Fri Aug 21, 2015 12:23 pm

XoD wrote:@Lt.Cmdr.Ivan: sorry it's seems than the kernel version used for imx6 project (base Linux v3.14 modified for cuboxi) doesn't support Wandboard quad revb1.
=> The kernel used don't have the dts for Wandboard quad revb1
I don't know what would be the best way to solve this issue, backport change from newer kernel to currently used, or tried to used a more recent kernel.
Fyi: new kernel used in OpenELEC will be https://github.com/SolidRun/linux-fslc
ETA don't know. But I think not far away.

Also I made github post about u-boot bootloader issue (https://github.com/OpenELEC/OpenELEC.tv ... -131520045).
vpeter
 
Posts: 78
Joined: Wed Dec 24, 2014 7:44 am

Re: OpenELEC

Postby kk31 » Fri Aug 21, 2015 4:11 pm

XoD wrote:Hello, sorry all for the respond delay and thank you for testing.

@Lt.Cmdr.Ivan: sorry it's seems than the kernel version used for imx6 project (base Linux v3.14 modified for cuboxi) doesn't support Wandboard quad revb1.
=> The kernel used don't have the dts for Wandboard quad revb1
I don't know what would be the best way to solve this issue, backport change from newer kernel to currently used, or tried to used a more recent kernel.

@kk31: no idea.

I have build a recent version of image for Wandboard (with a recent u-boot-imx, 2015-07-rc3_156598a)
The file should be available here : http://www.xoddark.com/Public/openelec/ ... -20150821/


Hi,

image does not boot at WB dual:

U-Boot SPL 2015.10-rc2 (Aug 21 2015 - 12:08:10)


U-Boot 2015.10-rc2 (Aug 21 2015 - 12:08:10 +0000)

CPU: Freescale i.MX6DL rev1.1 at 792MHz
Reset cause: POR
Board: Wandboard rev B1
I2C: ready
DRAM: 1 GiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
*** Warning - bad CRC, using default environment

No panel detected: default to HDMI
Display: HDMI (1024x768)
In: serial
Out: serial
Err: serial
Net: FEC [PRIME]
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc0 is current device
reading boot.scr
** Unable to read file boot.scr **
reading zImage
** Unable to read file zImage **
Booting from net ...
BOOTP broadcast 1
*** Unhandled DHCP Option in OFFER/ACK: 42
kk31
 
Posts: 2
Joined: Sat Aug 15, 2015 3:35 pm

Re: OpenELEC

Postby Lt.Cmdr.Ivan » Sat Aug 22, 2015 1:01 pm

@kk31:
In my case the following thing worked.

1. Install this image on your SD-Card
OpenELEC-imx6.arm-6.0-devel-20150618185638-r21049-g2018d81-wandboard.img.gz
http://www.xoddark.com/Public/openelec/build/imx6_upstream_uboot/OpenELEC-imx6.arm-6.0-devel-20150618185638-r21049-g2018d81-wandboard.img.gz

2. Startup the system and configure it

3. Copy this file to the Update folder of the OpenElec System
OpenELEC-imx6.arm-6.0-devel-20150821141224-r21232-g32cc9ac.tar
http://www.xoddark.com/Public/openelec/build/6.0-devel-20150821/OpenELEC-imx6.arm-6.0-devel-20150821141224-r21232-g32cc9ac.tar

4. Let the system restart and update itself
5. Voila the new image is running

Can you get the system running that way?

@XoD
Thanks for your reply, that enlightens me regarding that problem.

If i install your compiled version as described above, why is it working but if i take the image directly it isn't ?
I am strangely confused by this behavior, because the resulting system should be identical, or shouldn't it?

I tried the above mentioned upstream image on my Cubox but it didn't boot at all.
Did i misunderstand the concept of the upstream boot version regarding the cross compatibility with the cubox?

@vpeter
Regarding the new kernel,
does that mean it'll be easier in the future to get the wandboard fully integrated in the openelec build tree?

@all
Thank you for your hard work regarding the wandboard/cubox/udoo/(all systems i forgot) openelec work.
Lt.Cmdr.Ivan
 

Re: OpenELEC

Postby Lt.Cmdr.Ivan » Sat Aug 22, 2015 1:24 pm

Hello,

I created to Builds based on the upstream boot with the official Openelec 5.08 and 5.95.3 systems.
Downloads are possible under:
http://pictureman2.bplaced.net/public/Wandboard-Openelec/

Tested and working on a Wandboard Quad BI


P.S: Wifi+BT naturally doesn't work with these builds. If you need Wifi you are better suited with the xod builds.
Lt.Cmdr.Ivan
 

Re: OpenELEC

Postby XoD » Mon Nov 02, 2015 10:00 pm

Hello, sorry for the long time without news.

If someone is interrested to test a new image with openelec 6.0 for wandboard, i have build images.
But I haven't tested it, if you encounter problem, report it.

You find them here
XoD
 
Posts: 43
Joined: Thu May 29, 2014 12:52 pm

Re: OpenELEC

Postby Wig » Wed Nov 04, 2015 3:43 am

XoD:
Thanks for your release!! Very useful!
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: OpenELEC

Postby asplundj » Sun Nov 15, 2015 7:31 pm

XoD wrote:Hello, sorry for the long time without news.

If someone is interrested to test a new image with openelec 6.0 for wandboard, i have build images.
But I haven't tested it, if you encounter problem, report it.

You find them here


Would that build work on wandboard dual or is for quad only? How big sd-card do I need?
asplundj
 
Posts: 14
Joined: Thu Nov 12, 2015 10:56 am

Re: OpenELEC

Postby XoD » Sun Nov 15, 2015 8:59 pm

Normally, it should work for quad and dual.
If you don't have the media on the board, 1 or 2 giga octets sd card should be enough.
XoD
 
Posts: 43
Joined: Thu May 29, 2014 12:52 pm

PreviousNext

Return to Software - XBMC

Who is online

Users browsing this forum: No registered users and 3 guests

cron