XBMC on the Wandboard

XBMC subforum

Re: XBMC on the Wandboard

Postby LeoKesler » Thu Feb 20, 2014 2:53 am

@CruX, do you have plans to update your PKGBUILD to use the official xbmc imx ?

https://github.com/xbmc-imx6/xbmc
LeoKesler
 
Posts: 26
Joined: Sat Aug 31, 2013 10:56 am

Re: XBMC on the Wandboard

Postby CruX » Thu Feb 20, 2014 8:10 am

Sure, I just found out about this repo yesterday.

I built it and it was not able to render 1080p as good as wolfgars imx-wip (yet). I had some weird distortions.
As soon as this thing works (I'll do a build every day or so), I'll change my PKGBUILD of course,

By the way, archlinux has more or less merged loads of imx6 related PKGBUILDs which are heavily based on mine. It would probably even work running xbmc without compiling anyhing yourself at all.
I have not tested them yet though.


Cheers,
CruX
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

Re: XBMC on the Wandboard

Postby LeoKesler » Thu Feb 20, 2014 11:20 am

CruX wrote:Sure, I just found out about this repo yesterday.

I built it and it was not able to render 1080p as good as wolfgars imx-wip (yet). I had some weird distortions.
As soon as this thing works (I'll do a build every day or so), I'll change my PKGBUILD of course,


To be honest, using your PKGBUILD, I am able to compile the branch of smallint. And it was working great.

However, the koying branch I never been able to compile, because of this error:

http://pastebin.com/40CipFas

CruX wrote:By the way, archlinux has more or less merged loads of imx6 related PKGBUILDs which are heavily based on mine. It would probably even work running xbmc without compiling anyhing yourself at all.
I have not tested them yet though.
Cheers,
CruX

I still learning archlinux... I dont know how to search by PKGBUILDs, except by Google. Any hint ?
LeoKesler
 
Posts: 26
Joined: Sat Aug 31, 2013 10:56 am

Re: XBMC on the Wandboard

Postby setti » Thu Feb 20, 2014 2:00 pm

LeoKesler wrote:I still learning archlinux... I dont know how to search by PKGBUILDs, except by Google. Any hint ?

Im using https://wiki.archlinux.org/index.php/yaourt for this. But you can use download the PKGBUILDs manually as well via https://aur.archlinux.org/
setti
 
Posts: 39
Joined: Fri Jan 10, 2014 6:15 pm

Re: XBMC on the Wandboard

Postby LeoKesler » Thu Feb 20, 2014 4:14 pm

setti wrote:
LeoKesler wrote:I still learning archlinux... I dont know how to search by PKGBUILDs, except by Google. Any hint ?

Im using https://wiki.archlinux.org/index.php/yaourt for this. But you can use download the PKGBUILDs manually as well via https://aur.archlinux.org/


Thank you ! I will check later.

About my error : http://pastebin.com/40CipFas

I think the problem was the compiler was using wrong *GL*.h . The compile was using the original /usr/include/GL* and thas was the problem

So, I replace the files in /usr/include by the files in /opt/fsl/include/GL* and its compiling.
LeoKesler
 
Posts: 26
Joined: Sat Aug 31, 2013 10:56 am

Re: XBMC on the Wandboard

Postby abreaks » Thu Feb 27, 2014 2:12 pm

I keep having the halting issue with both the new Yocto image and the old Yocto image from Wolgar. I went so far as to buy a new wandboard quad to make sure it isn't an issue specific to my board.

I did get a potential clue last night after letting XBMC run for ages. It complained about a network plugin and asked if I wanted to disable it. Of course the software was halted so I couldn't say yes but it gives me an idea. Is there a way to edit config files is such a way as to have a minimal functional XBMC setup? I could then switch various features and plugin back on until I found what was causing the problem. I ask about editting config files because I only get 30-90 seconds in XBMC before it starts halting for minutes to hours to days with 15 second windows that the interface is refreshed and accepting input. Even SSH seems stalled.

In researching my halting problem I found a bunch of people that had the same problem with the early images. They never fixed the problem and simply moved on and stopped trying. So there may be a real issue that effects certain people that seems rare only because those effected have given up. Maybe it effects early Wandboards only? I got mine over a year ago. I guess having a new unit will help test that theory.
abreaks
 
Posts: 7
Joined: Mon Jan 13, 2014 5:53 pm

Re: XBMC on the Wandboard

Postby abreaks » Fri Feb 28, 2014 2:57 pm

Ok - I managed to turn off Network Manager. XMBC is still having the halting problem with it off. Perhaps I will try turning every add-on off next.
abreaks
 
Posts: 7
Joined: Mon Jan 13, 2014 5:53 pm

Re: XBMC on the Wandboard

Postby jsntyyl » Sun Mar 02, 2014 2:15 pm

I have archlinuxarm installed and installed the xbmc-imx-git with pacman, but when I start xbmc via systemctl start xbmc, the monitor have no the default xbmc gui, so I check the status of xbmc and I found that it crashed, here is the crash log, they are all NOTICE, no ERROR, if anyone can point out the problem.
############## XBMC CRASH LOG ###############

################ SYSTEM INFO ################
Date: 2014年 03月 02日 星期日 13:30:55 CST
XBMC Options:
Arch: armv7l
Kernel: Linux 3.0.35-5-ARCH #1 SMP PREEMPT Thu Jan 23 14:43:31 MST 2014
Release: Arch Linux ARM
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

13:30:52 T:1111035904 NOTICE: special://profile/ is mapped to: special://masterprofile/
13:30:52 T:1111035904 NOTICE: -----------------------------------------------------------------------
13:30:52 T:1111035904 NOTICE: Starting XBMC (13.0-ALPHA12 Git:20140226-527c967). Platform: ARM Linux 32-bit
13:30:52 T:1111035904 NOTICE: Using Release XBMC x32 build, compiled Feb 27 2014 by GCC 4.8.2 for ARM Linux 32-bit 3.13.2
13:30:52 T:1111035904 NOTICE: Running on Linux 32-bit (Arch Linux ARM, 3.0.35-5-ARCH armv7l)
13:30:52 T:1111035904 NOTICE: Host CPU: ARMv7 Processor rev 10 (v7l), 4 cores available
13:30:52 T:1111035904 NOTICE: ARM Features: Neon enabled
13:30:52 T:1111035904 NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
13:30:52 T:1111035904 NOTICE: special://xbmcbin/ is mapped to: /usr/lib/xbmc
13:30:52 T:1111035904 NOTICE: special://masterprofile/ is mapped to: /var/lib/xbmc/.xbmc/userdata
13:30:52 T:1111035904 NOTICE: special://home/ is mapped to: /var/lib/xbmc/.xbmc
13:30:52 T:1111035904 NOTICE: special://temp/ is mapped to: /var/lib/xbmc/.xbmc/temp
13:30:52 T:1111035904 NOTICE: The executable running is: /usr/lib/xbmc/xbmc.bin
13:30:52 T:1111035904 NOTICE: Local hostname: wbquad
13:30:52 T:1111035904 NOTICE: Log File is located: /var/lib/xbmc/.xbmc/temp/xbmc.log
13:30:52 T:1111035904 NOTICE: -----------------------------------------------------------------------
13:30:52 T:1111035904 NOTICE: load settings...
13:30:52 T:1111035904 NOTICE: Found 1 Lists of Devices
13:30:52 T:1111035904 NOTICE: Enumerated ALSA devices:
13:30:52 T:1111035904 NOTICE: Device 1
13:30:52 T:1111035904 NOTICE: m_deviceName : sysdefault:CARD=sgtl5000audio
13:30:52 T:1111035904 NOTICE: m_displayName : sgtl5000-audio
13:30:52 T:1111035904 NOTICE: m_displayNameExtra: Analog
13:30:52 T:1111035904 NOTICE: m_deviceType : AE_DEVTYPE_PCM
13:30:52 T:1111035904 NOTICE: m_channels : FL,FR
13:30:52 T:1111035904 NOTICE: m_sampleRates : 8000,11025,16000,22050,32000,44100,48000,96000
13:30:52 T:1111035904 NOTICE: m_dataFormats : AE_FMT_S24NE4,AE_FMT_S16NE,AE_FMT_S16LE
13:30:52 T:1111035904 NOTICE: Device 2
13:30:52 T:1111035904 NOTICE: m_deviceName : sysdefault:CARD=imxspdif
13:30:52 T:1111035904 NOTICE: m_displayName : imx-spdif
13:30:52 T:1111035904 NOTICE: m_displayNameExtra: S/PDIF
13:30:52 T:1111035904 NOTICE: m_deviceType : AE_DEVTYPE_IEC958
13:30:52 T:1111035904 NOTICE: m_channels : FL,FR
13:30:52 T:1111035904 NOTICE: m_sampleRates : 32000,44100,48000
13:30:52 T:1111035904 NOTICE: m_dataFormats : AE_FMT_AC3,AE_FMT_DTS,AE_FMT_S24NE4,AE_FMT_S16NE,AE_FMT_S16LE
13:30:52 T:1111035904 NOTICE: Device 3
13:30:52 T:1111035904 NOTICE: m_deviceName : sysdefault:CARD=imxhdmisoc
13:30:52 T:1111035904 NOTICE: m_displayName : imx-hdmi-soc
13:30:52 T:1111035904 NOTICE: m_displayNameExtra: HDMI
13:30:52 T:1111035904 NOTICE: m_deviceType : AE_DEVTYPE_HDMI
13:30:52 T:1111035904 NOTICE: m_channels : FL,FR
13:30:52 T:1111035904 NOTICE: m_sampleRates : 32000,44100,48000
13:30:52 T:1111035904 NOTICE: m_dataFormats : AE_FMT_LPCM,AE_FMT_DTSHD,AE_FMT_TRUEHD,AE_FMT_EAC3,AE_FMT_DTS,AE_FMT_AC3,AE_FMT_AAC,AE_FMT_S16NE,AE_FMT_S16LE
13:30:52 T:1111035904 NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
13:30:52 T:1111035904 NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
13:30:52 T:1111035904 NOTICE: Default DVD Player: dvdplayer
13:30:52 T:1111035904 NOTICE: Default Video Player: dvdplayer
13:30:52 T:1111035904 NOTICE: Default Audio Player: paplayer
13:30:52 T:1111035904 NOTICE: Disabled debug logging due to GUI setting. Level 0.
13:30:52 T:1111035904 NOTICE: Log level changed to 0
13:30:52 T:1111035904 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:30:52 T:1111035904 NOTICE: Loaded playercorefactory configuration
13:30:52 T:1111035904 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:30:52 T:1111035904 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:30:52 T:1111035904 NOTICE: LoadFromXML - unable to load:/var/lib/xbmc/.xbmc/userdata/wakeonlan.xml
05:30:53 T:1133339696 NOTICE: Thread ActiveAE start, auto delete: false
05:30:53 T:1143993392 NOTICE: Thread AESink start, auto delete: false
05:30:53 T:1111035904 NOTICE: Running database version Addons16
05:30:54 T:1111035904 NOTICE: ADDONS: Using repository repository.xbmc.org
05:30:54 T:1154479152 NOTICE: Thread PeripBusCEC start, auto delete: false
05:30:54 T:1164964912 NOTICE: Thread PeripBusUSBUdev start, auto delete: false
05:30:54 T:1111035904 NOTICE: Initialize - graphics sysfs is read-only
05:30:54 T:1111035904 NOTICE: InitWindowSystem: Using EGL Implementation: iMX


############### END LOG FILE ################

############ END XBMC CRASH LOG #############
jsntyyl
 
Posts: 4
Joined: Mon Feb 17, 2014 9:03 am

Re: XBMC on the Wandboard

Postby johnc32779 » Thu Mar 06, 2014 7:29 pm

So close, but no cigar yet.

imx-lib:
Code: Select all
johnc@alarm:/opt/PKGBUILDs-master/alarm/imx-lib$ uname -a
Linux alarm 3.0.35_4.1.0-5-ARCH+ #1 SMP PREEMPT Tue Feb 18 14:23:26 MST 2014 armv7l GNU/Linux

johnc@alarm:/opt/PKGBUILDs-master/alarm/imx-lib$ makepkg
==> Making package: imx-lib 3.10.9_1.0.0-1 (Thu Mar  6 12:00:18 MST 2014)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> fsl-bsp-kernel=4.1.0
  -> fsl-bsp-kernel-headers=4.1.0
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.


Starting out with a fresh archlilnux install, I have successfully installed alarm: firmware-imx, imx-vpu, libflsvpuwarp, core: gpu-viv-bin-mx6q-fb, imx. But I can not figure out how to satisfy the imx-lib dependencies above.

If appears as if my situation is very similar to kohonen's post on Feb 16.

What am I missing?
johnc32779
 
Posts: 6
Joined: Mon Jan 20, 2014 11:53 pm

Re: XBMC on the Wandboard

Postby kohonen » Fri Mar 07, 2014 4:17 pm

try to change them to
fsl-bsp-kernel=3.0.35_4.1.0
fsl-bsp-kernel-headers=3.0.35_4.1.0

in the PKGBUILD file
kohonen
 
Posts: 16
Joined: Sun Feb 02, 2014 11:42 am

PreviousNext

Return to Software - XBMC

Who is online

Users browsing this forum: XoD and 3 guests