Ubuntu won't boot unless display is attached

Discuss Ubuntu related items.

Ubuntu won't boot unless display is attached

Postby veracity » Sat Apr 11, 2015 4:14 pm

Hello,
I've a wandboard quad, and have just downloaded and successfully installed the latest ubuntu release:
http://www.wandboard.org/images/downloa ... 312.img.xz

The problem is that i want to use the board headless via ssh. Unfortunately, the board only obtains a DHCP address via LAN when plugged into a monitor (my TV).

I've tried to edit the xorg.conf file as per the link below, but unsuccessfully:
http://ubuntuforums.org/showthread.php?t=1223504

Other solutions are to tell GRUB to boot into text mode (GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"), but I can't find GRUB files in the installation - so assume it's uBoot that Wandboard uses instead of GRUB?

How do i configure uBoot to boot into text only mode (if indeed, this is the correct solution at all)?

(the previous 2014 ubuntu image didn't seem to have this problem)
veracity
 
Posts: 5
Joined: Sat Aug 02, 2014 9:00 am

Re: Ubuntu won't boot unless display is attached

Postby veracity » Sat Apr 11, 2015 7:39 pm

Solved (although now my darned external drives don't mount):
disable startx/lightdm
echo "manual" | sudo tee -a /etc/init/lightdm.override
veracity
 
Posts: 5
Joined: Sat Aug 02, 2014 9:00 am


Return to Software - Ubuntu

Who is online

Users browsing this forum: No registered users and 5 guests

cron