Ethernet in Ubuntu 14.04 with Wandboard Quad

Discuss Ubuntu related items.

Ethernet in Ubuntu 14.04 with Wandboard Quad

Postby Lake-end » Wed Aug 08, 2018 11:50 am

Hello, just registered o/

I just purchased bunch of Quads and I am wanting to run Ubuntu 14.04 on them (because of "reasons"). I have hard time getting the ethernet working on these units.

"ETH0 could not attach PHY" errors and such.

Ethernet works on 16.04 but I cant currently use as I specifically require these units to run 14.04. Is there any way of getting the ethernet working with older 14.04?
Both Ubuntu images were downloaded from Wandboards site.
Lake-end
 
Posts: 2
Joined: Wed Aug 08, 2018 11:46 am

Re: Ethernet in Ubuntu 14.04 with Wandboard Quad

Postby ClayMontgomery » Sat Aug 11, 2018 4:59 pm

The issue is that the newer (rev D1 boards) require an updated device tree so that the Ethernet PHY gets powered up. Older Wandboards did not require that because they have no PMIC.
Running the older kernel should be OK, but, you will have to update the device tree that is used on boot.

Regards, Clay
ClayMontgomery
 
Posts: 96
Joined: Tue Nov 19, 2013 9:14 pm

Re: Ethernet in Ubuntu 14.04 with Wandboard Quad

Postby Lake-end » Mon Aug 13, 2018 7:16 am

So can I just take the "imx6q-wandboard-revd1.dtb" file from the 16.04 boot image and drop it to the older systems boot image?
I assume some config file "somewhere" needs to be modified to tell the system to use the new dtb file?

Googling and searching this forum does not exactly provide any simple guide for this. Any pointers?
Lake-end
 
Posts: 2
Joined: Wed Aug 08, 2018 11:46 am

Re: Ethernet in Ubuntu 14.04 with Wandboard Quad

Postby ClayMontgomery » Mon Aug 13, 2018 2:57 pm

I think that can only work if the kernel versions were exactly the same between Ubuntu 14 and 16, which is not the case. Device trees are compiled against the specific kernel that they will be used with.
However, I have done that successfully with Yocto when the kernel was the same version.
U-boot uses the device tree that is named in this file:

/boot/extlinux/extlinux.conf

We have a similar situation with Yocto, in that only the latest versions (Rocko and Pyro) can be used on rev D1 boards, if you want the Ethernet port to work.

Regards, Clay
ClayMontgomery
 
Posts: 96
Joined: Tue Nov 19, 2013 9:14 pm

Re: Ethernet in Ubuntu 14.04 with Wandboard Quad

Postby nightshift » Thu Aug 16, 2018 12:04 pm

Hello,

I'm facing the very same issue with ubuntu 14.04. I'm using several Wandboards (SOLO, DUAL, QUAD and QUADplus).

Can anyone provide working device tree files?
nightshift
 
Posts: 1
Joined: Thu Aug 16, 2018 10:25 am


Return to Software - Ubuntu

Who is online

Users browsing this forum: No registered users and 4 guests

cron