Gstreamer doesn't stream with kernel 3.14.52 - Wandboard

Discuss Ubuntu related items.

Gstreamer doesn't stream with kernel 3.14.52 - Wandboard

Postby Rashmi Muruganandam » Wed Feb 14, 2018 1:27 pm


We are using i.MX6 Wandboard with Linux3.14.52-Ubuntu-14.04. We are trying to stream the MIPI camera using Gstreamer application.
While running the application using below command, we are getting some errors and not able to stream it.

# gst-launch-0.10 -v mfw_v4lsrc device="/dev/video0" preview=0 bg=1 fps-n=30 ! mfw_isink

We have tried with gst-launch & gst-launch-1.0 also still issue remains same. We have attached Log file also with this post.

We have tried with below command which show the error:
# gst-launch-1.0 imxv4l2videosrc device=/dev/video1 ! imxeglvivsink
ERROR: pipeline could not be constructed: no element "imxv4l2videosrc".

We are trying to install gstreamer-imx packages, but we are facing some build errors in it.
Meanwhile, we just want to know the proper pipeline command to make it work.

Please give me suggestion to resolve this issue.

Thanks in advance.

Rashmi Ghoael
Log file captured while running the gstreamer application
(1.19 KiB) Downloaded 122 times
Rashmi Muruganandam
Posts: 3
Joined: Thu Nov 23, 2017 12:29 pm

Return to Software - Ubuntu

Who is online

Users browsing this forum: No registered users and 6 guests