Welcome to try the Ubuntu 16.04-LTS-server image

Discuss Ubuntu related items.

Welcome to try the Ubuntu 16.04-LTS-server image

Postby Wig » Thu Mar 24, 2016 10:21 am

As title, the Wanboard owners can enjoy the pre-experienced for our test image with official kernel 4.1!

Although it's just test version, but almost working for all functions! welcome to download it find more and more problems together :lol: ,
these problems will be worth to improve the final release next month (with desktop).
Thank you!

welcome to discuss on this post!

link: https://goo.gl/zr34yd


By the way, the source code of kernel 4.1 is already push on wandboard official github!
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby SAGEE » Thu Mar 24, 2016 6:33 pm

Does this build have the vivante drivers preinstalled?
SAGEE
 
Posts: 7
Joined: Wed Mar 23, 2016 12:47 pm

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby Wig » Fri Mar 25, 2016 2:12 am

Hello SAGEE:

Of course, but this vivante driver is too new for kernel 4.1, so application layer has not support on Ubuntu 16.04 now, I will trying to porting vivante libraries recently,
you can help me if you can't wait :lol: .
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby tolrtd » Fri May 13, 2016 5:46 pm

Hi Wig,

Thank you for this image. Is the final release out yet? And is Vivante working?

Thanks!
tolrtd
 
Posts: 4
Joined: Sun Jul 13, 2014 2:10 pm

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby Wig » Mon May 16, 2016 4:11 pm

Final testing now...
Maybe coming soon in these 2 weeks.
Thank you for your patientce!

Vivante is working using kernel 4.1 (at least glx and egl test working :oops: )
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby tolrtd » Mon May 16, 2016 7:45 pm

Hi Wig,

Thanks for the information.

Do you see any reason why we would have trouble getting Chromium GPU accelerated (specifically, I need a proper V-sync signal to trigger the requestAnimationFrame method) on X11? Or is there still a shortcoming here?

Thanks!
tolrtd
 
Posts: 4
Joined: Sun Jul 13, 2014 2:10 pm

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby Wig » Thu May 19, 2016 2:35 am

If you have Chromium GPU accelerated (webGL) requirement, you can refer the yocto image and observe the dependency, the 16.04 not support webGL yet, maybe update in the future, thank you.
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby tolrtd » Fri May 27, 2016 1:05 pm

Hi Wig,

The Yocto image also has trouble doing this; X11 won't run under the GPU. Do you have any ideas on a direction I could take to accomplish this? Do you know of any plans to make a Wandboard with an iMX7 that may solve this?

Thanks!
tolrtd
 
Posts: 4
Joined: Sun Jul 13, 2014 2:10 pm

Re: Welcome to try the Ubuntu 16.04-LTS-server image

Postby Wig » Fri May 27, 2016 5:59 pm

tolrtd:

Which kernel did you use on yocto image? Kernel 4.1.15? Seems like no match between vivante library on application layer and your gpu version on kernel.

IMX7? This CPU no support gpu function :(

Thank you
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am


Return to Software - Ubuntu

Who is online

Users browsing this forum: No registered users and 2 guests

cron