Dual Lite Ubuntu: disable boot into desktop

Discuss Ubuntu related items.

Dual Lite Ubuntu: disable boot into desktop

Postby Galto2000 » Tue Mar 15, 2016 2:32 pm

Howdy folks,

I got a Wandboard Dual Lite, and I grabbed one of the latest Ubuntu images (14.04 LTS).

How can I force the Wandboard to boot up in terminal/text mode by default and only start the desktop via the command line when I need to?

I am not familiar with u-boot, and in GRUB this would be just a very simple edit. Is there something similar I can do here to prevent the Wandboard from booting into the desktop?

Thanks in advance

G
Galto2000
 
Posts: 2
Joined: Tue Mar 15, 2016 2:25 pm

Re: Dual Lite Ubuntu: disable boot into desktop

Postby Galto2000 » Tue Mar 15, 2016 7:58 pm

Here is a solution that worked for me: rename the lxdm.conf file

$ sudo mv /etc/init/lxdm.conf /etc/init/lxdm.conf.nostart
(to restore it, simply move it back to it's original file name: $ sudo mv /etc/init/lxdm.conf.nostart /etc/init/lxdm.conf)
To start it from the command line: $ startx

Ref: http://ubuntuforums.org/showthread.php?t=1604728

G
Galto2000
 
Posts: 2
Joined: Tue Mar 15, 2016 2:25 pm

Re: Dual Lite Ubuntu: disable boot into desktop

Postby Tapani » Wed Mar 16, 2016 2:40 am

Thank you Galto2000 for posting the solution after you figure it out.
Tapani
Site Admin
 
Posts: 701
Joined: Tue Aug 27, 2013 8:32 am


Return to Software - Ubuntu

Who is online

Users browsing this forum: No registered users and 3 guests