Scavenger Hunt

This subforum is for discussing blogposts/articles and for other comments about the wandboard site.

Re: Scavenger Hunt

Postby Wig » Mon Jun 01, 2015 7:57 am

Hello seb-esperanto:

Although these two zImage has different commit HASH code, but their GPU driver were same.

When I replace zImage using 3.10.53-1.1.0_ga-wandboard-06036-gf5f4aea, it failed after I type xbmc-standalone, it was a same error message as you post,
but the XBMC still could auto showing the GUI when I boot the wandboard, I think the xbmc run in background already,
Code: Select all
root@geexbox:~# ps aux | grep "xbmc"
523 root     {runxbmc} /bin/sh /usr/bin/runxbmc --standalone -fs -l /var/run/lirc/lircd
530 root     /usr/lib/xbmc/xbmc.bin --standalone -fs -l /var/run/lirc/lircd


maybe it's not a issue? However, I will continue check this problem.
In addition, thanks for your suggest about how to improve the instruction!
Wig
Site Admin
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: Scavenger Hunt

Postby Tapani » Mon Jun 01, 2015 10:11 am

seb-esperanto,

the problem seems to be the GPU driver version. XBMC userland requires the old (3.10.17) driver, the default in our kernel is the new (3.10.53).

You can change this with a kernel menuconfig: (drivers -> mxc support drivers -> mxc vivante gpu -> gpu driver version -> v3.10.17)

Thank you for pointing this out! And sorry for forgetting this detail when we wrote the wiki :(

Your post contains a lot of useful details for others wanting to create an SD card. May we add some of that to the wiki?
We created an account for you there if you prefer to edit yourself. (Check your PM)

Feel free to hack our clumsy description to whatever you feel like :-)
Tapani
Site Admin
 
Posts: 674
Joined: Tue Aug 27, 2013 8:32 am

Re: Scavenger Hunt

Postby Chris81T » Tue Jun 02, 2015 9:16 pm

Hi @all,

I was glad to read about the "May 13 2015 - Wandboard Scavenger Hunt - Kodi / XMBC" article. Great work! You have created the image using geexbox. Is it also possible to "simply" switch to another xbmc / kodi distro like OpenElec? Maybe you can give some hints or a recipe? I have found some openelec-developer images build for the wandboard. But sadly sometimes it ends with some errors (wont boot correctly / everything is resetted).

Great will be a stable wandboard image with the latest stable kodi version. (The geexbox image has told me, that a newer image is available - Also after a few minutes I have only a black screen).

Again good job you have made. Maybe someone has created a newer image with a current version of kodi and can provide it?


Cheers!
Chris81T
 
Posts: 8
Joined: Fri Dec 05, 2014 8:33 am

Re: Scavenger Hunt

Postby Tapani » Thu Jun 04, 2015 5:14 am

Chris81T,

the image in the downloads section has the screensaver issue fixed. We hear many good things about OpenElec Kodi, so we probably should make an image based on that.
(It probably won't be on the top of the list, since we just did a Kodi, and have many other interesting images brewing ... but in a few weeks maybe)

We are certainly open to suggestions which images to do! (Including which OpenElec image to base the next Kodi on)
Tapani
Site Admin
 
Posts: 674
Joined: Tue Aug 27, 2013 8:32 am

Re: Scavenger Hunt

Postby seb-esperanto » Thu Jun 11, 2015 6:43 pm

Dear Wig,
Dear Tapani,
thank you for your answers and sorry for my late reply... I was very busy at work...

I do confirm that xbmc-standalone is not the right command to launch xbmc : same error appears even in a working image, you're right !

I also confirm that when building the kernel after choosing drivers -> mxc support drivers -> mxc vivante gpu -> gpu driver version -> v3.10.17 with make menu config, everything works fine ! Thank you very much ! :D

Thank you for trusting me about the wandboard wiki !
I just updated the page about geexbox sdcard creation, adding a Step 0 and fixing/adding details in other steps.

seb-esperanto
seb-esperanto
 
Posts: 8
Joined: Thu May 14, 2015 6:15 pm

Re: Scavenger Hunt

Postby blackibiza » Sun Jun 14, 2015 3:01 pm

Hi

I've a problem with Wifi on the Wandboard Quad Rev. B with latest Kodi snapshot: the wifi card isn't recocgnized at all even if the rfkill is enabled looking at the dmesg log

How did you solve it?
blackibiza
 
Posts: 13
Joined: Wed Dec 04, 2013 11:24 am

Re: Scavenger Hunt

Postby blue_z » Sun Jun 14, 2015 10:37 pm

blackibiza wrote:I've a problem with Wifi on the Wandboard Quad Rev. B with latest Kodi snapshot: the wifi card isn't recocgnized at all even if the rfkill is enabled looking at the dmesg log
Analyze your `dmesg` better, and look for all mesages with "brcm".
Most likely issue is that you're missing the proper firmware files in /lib/firmware/brcm or they're not getting installed by the driver.
Code: Select all
# dmesg | grep brcm
brcmfmac: F1 signature read @0x18000000=0x16044330
brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Oct 25 2011 19:34:12 version 5.90.125.104
brcmfmac: brcmf_fws_init: enabled bdcv2 tlv signaling [1]
#
(My kernel for Quad Rev C1 does not have brcm driver debug enabled, so this output maybe more sparse than yours.)

FWIW I got Linux 3.10.53-1.1.0_ga-wandboard and Kodi 14.2-Helix (directly to the framebuffer, i.e. no X11) working the other day, all built with Buildroot 2015.05. HW-assisted video decode is working, however I'm seeing (transient) MPEG2 interlace or deinterlace artefacts (depending on source vs output conversion) with recorded ATSC TV files (i.e. .wtv files on a Win7 PC). More details to follow (e.g. a patch for Buildroot) once more testing is done .

Regards

ADDENDUM

The Buildroot patch (as well as an SDcard image) for Kodi on Wandboard is described/available here.
blue_z
 
Posts: 34
Joined: Sat Jun 13, 2015 12:12 am
Location: USA

Re: Scavenger Hunt

Postby synportack24 » Mon Jul 06, 2015 9:34 pm

Tapani wrote:Chris81T,

the image in the downloads section has the screensaver issue fixed. We hear many good things about OpenElec Kodi, so we probably should make an image based on that.
(It probably won't be on the top of the list, since we just did a Kodi, and have many other interesting images brewing ... but in a few weeks maybe)

We are certainly open to suggestions which images to do! (Including which OpenElec image to base the next Kodi on)


Small request, if you do make a OpenElec Image would you mind adding libcec support like the normal OpenElec builds? The revC1 should have CEC support right?
That would make my hopes and dreams come true.
synportack24
 
Posts: 17
Joined: Mon Oct 20, 2014 10:56 pm

Re: Scavenger Hunt

Postby kwalter » Fri Dec 04, 2015 7:54 am

Hello there,
have problems with the image files for my Wandboard quad, I downloaded from the http://www.wandboard.org page.

http://www.wandboard.org/images/downloa ... 150511.zip screen displays the logo of Wandboard.org for a few seconds and then dark.

http://www.wandboard.org/images/downloa ... 150514.zip
is working!

http://www.wandboard.org/images/downloa ... 150520.zip screen displays the logo of Wandboard.org for a few seconds and then dark.

http://www.wandboard.org/images/downloa ... 150511.zip screen displays the logo of Wandboard.org for a few seconds and then dark.

Have a monitor via HDMI DVI Adapter connected and already several times on Windows 10 Pro with Win32DiskImager and OpenSuse 13.2 with DD or ImageWriter tried the image files to write to an SD card, and also used various SD cards.

Except for the debian-8 Xfce Wandboard-20150514 nothing works, what am I doing wrong?

Sorry for my bad english my natural language is German, use the Google translator.

Many greetings
kwalter
kwalter
 
Posts: 1
Joined: Thu Dec 03, 2015 10:51 pm

Re: Scavenger Hunt

Postby Tapani » Tue Jan 05, 2016 10:33 am

kwalter,

sorry for the long delay.

We have not noticed problems with the images we put online, and we usually test them on a few boards.
Which WB do you have (solo, dual, quad?). Do you know if you have rev C or an older revision? (when did you buy it)
Tapani
Site Admin
 
Posts: 674
Joined: Tue Aug 27, 2013 8:32 am

PreviousNext

Return to Article talkback and site feedback

Who is online

Users browsing this forum: No registered users and 11 guests

cron