Wandboard PCIE support

This is the place for software discussions not having a dedicated subforum

Wandboard PCIE support

Postby anjo » Wed Jan 24, 2018 2:34 am

Hi all
i have a wandboard with EDM1-IMX6-sd REV A1 som board. i just need to enable the PCIE support in kernel config and dtb . this is for interfacing a WiFi card with PCIE support. From WiFi card PCIE TX, RX, CLK and PCI_RST lines are connected. PCI_CLK_RQT and PCI_WAKE aren't connected.
For dtb i tried following change
+&pcie {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_pcie>;
+ reset-gpio = <&gpio3 31 1>;
+ status = "okay";
+};
for kernel defconfig followed the Linux reference manual 4.1.15
#
# Bus support
#
CONFIG_PCI=y
CONFIG_PCI_DOMAINS=y
CONFIG_PCI_SYSCALL=y
CONFIG_PCI_MSI=y
#
# PCI host controller drivers
#
CONFIG_PCIE_DW=y
CONFIG_PCI_IMX6=y

But when boots up kernel print shows
imx6q-pcie 1ffc000.pcie: phy link never came up
imx6q-pcie 1ffc000.pcie: DEBUG_R0: 0x00023600, DEBUG_R1: 0x08200000
imx6q-pcie 1ffc000.pcie: failed to initialize host
imx6q-pcie: probe of 1ffc000.pcie failed with error -22

i also tried the kernel configuration suggested in viewtopic.php?f=8&t=902, still same prints.
Is i am missing anything in kernel configuration ? Please suggest, any help is welcomed
anjo
 
Posts: 3
Joined: Thu Nov 17, 2016 6:45 am

Re: Wandboard PCIE support

Postby dtekarnatakaresults » Mon Jun 04, 2018 12:33 pm

DTE Karnataka Diploma Results:- Department of Technical Education, Karnataka conducted the Polytechnic exam in April-May month at various exam centers. Btelinx result
dtekarnatakaresults
 
Posts: 1
Joined: Mon Jun 04, 2018 12:24 pm


Return to Software - General

Who is online

Users browsing this forum: No registered users and 10 guests

cron