[SOLVED] Can't find hotspot created with Wandboard Dual D1

This is the place for software discussions not having a dedicated subforum

[SOLVED] Can't find hotspot created with Wandboard Dual D1

Postby evanjs » Thu Aug 03, 2017 2:20 pm

I am using a Wandboard Dual Rev D1.
When using the Ubuntu image provided by Wandboard, I am able to enable the WiFi module and set up hostapd, which seems to be broadcasting, but I am unable to see the created SSID on any other devices.
iwconfig shows wlan0 in master mode, bcmdhd is loaded, and ifconfig shows UP BROADCAST RUNNING MULTICAST, etc.
dmesg shows:
Code: Select all
[Wed Aug  2 22:27:54 2017] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[Wed Aug  2 22:27:54 2017] CFG80211-ERROR) check_dev_role_integrity : device role select failed

Which seem to be all that happen while hostapd is running.

As for the firmware, probing bcmdhd prints:
Code: Select all
[Wed Aug  2 22:11:28 2017] fw path is /lib/firmware/brcm/fw_bcmdhd.bin
[Wed Aug  2 22:11:28 2017] nvram_path is /lib/firmware/brcm/bcmdhd.cal

When trying to load the fw_bcmdhd_apsta.bin firmware, or setting op_mode to 2, I get a fault, which I can post if it is necessary.

In addition, the same behavior is observed with a u-boot image (from uboot-imx), a kernel compiled with Rev D1 support (wandboard-org/linux), and a Gentoo rootfs.

Does anybody have thoughts on what might need to be done?
If any further information is necessary, I'd be happy to provide such.


Edit: I should probably note that the board we were using previously--imx6dl-wandboard-revc1, I believe--had a BCM4330 and was using brcmfmac, which allowed hostapd to function properly.
According to a changelog I found on another thread:
3. wandboard rev.D1 replaces wifi chip BCM4330(USI WM-BN-BM-04) with BCM4339(Ampak AP6335).
The brcmfmac driver isn't compatible with AP6335 so far.
In the software release, it uses bcmdhd driver to be compatible with BCM4330 and BCM4339.
bcmdhd driver will detect the chip id and load the corresponding firmware and nvram file.

So I wonder if it has something to do with using bcmdhd instead of brcmfmac.
Last edited by evanjs on Sun Aug 06, 2017 5:00 am, edited 1 time in total.
Posts: 2
Joined: Thu Aug 03, 2017 12:52 pm

Re: Unable to find hotspot created with Wandboard Dual Rev D

Postby evanjs » Fri Aug 04, 2017 6:20 pm

Got it working.
Downloaded nvram_ap6335.txt and fw_bcm4339a0_ag.bin from https://github.com/rockchip-linux/rk-ro ... c/firmware and placed them in /lib/firmware/brcm
Code: Select all
modprobe bcmdhd firmware_path=/lib/firmware/brcm/fw_bcm4339a0_ag.bin nvram_path=/lib/firmware/brcm/nvram_ap6335.txt op_mode=2

Started hostapd and udhcpd and I'm able to connect and get an address from my iPhone.
Posts: 2
Joined: Thu Aug 03, 2017 12:52 pm

Return to Software - General

Who is online

Users browsing this forum: No registered users and 8 guests