wandboard quad wifi ap mode

This is the place for software discussions not having a dedicated subforum

Re: wandboard quad wifi ap mode

Postby graffitici » Fri Apr 18, 2014 10:42 pm

Hi all,

I'm also trying to set up the AP mode on the Wandboard. I have the 3.10.17 kernel, which is supposed to support at the very least the open AP mode.

iw list shows that the AP interface mode is supported, but I don't see anything about APs in "Supported TX frame types":
Code: Select all
# iw list
Wiphy phy0
   max # scan SSIDs: 10
   max scan IEs length: 2048 bytes
   Coverage class: 0 (up to 0m)
   Supported Ciphers:
      * WEP40 (00-0f-ac:1)
      * WEP104 (00-0f-ac:5)
      * TKIP (00-0f-ac:2)
      * CCMP (00-0f-ac:4)
      * CMAC (00-0f-ac:6)
   Available Antennas: TX 0 RX 0
   Supported interface modes:
       * IBSS
       * managed
       * AP
       * P2P-client
       * P2P-GO
       * P2P-device
   Band 1:
      Capabilities: 0x1020
         HT20
         Static SM Power Save
         RX HT20 SGI
         No RX STBC
         Max AMSDU length: 3839 bytes
         DSSS/CCK HT40
      Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
      Minimum RX AMPDU time spacing: 16 usec (0x07)
      HT RX MCS rate indexes supported: 0-7
      HT TX MCS rate indexes are undefined
      Bitrates (non-HT):
         * 1.0 Mbps
         * 2.0 Mbps (short preamble supported)
         * 5.5 Mbps (short preamble supported)
         * 11.0 Mbps (short preamble supported)
         * 6.0 Mbps
         * 9.0 Mbps
         * 12.0 Mbps
         * 18.0 Mbps
         * 24.0 Mbps
         * 36.0 Mbps
         * 48.0 Mbps
         * 54.0 Mbps
      Frequencies:
         * 2412 MHz [1] (20.0 dBm)
         * 2417 MHz [2] (20.0 dBm)
         * 2422 MHz [3] (20.0 dBm)
         * 2427 MHz [4] (20.0 dBm)
         * 2432 MHz [5] (20.0 dBm)
         * 2437 MHz [6] (20.0 dBm)
         * 2442 MHz [7] (20.0 dBm)
         * 2447 MHz [8] (20.0 dBm)
         * 2452 MHz [9] (20.0 dBm)
         * 2457 MHz [10] (20.0 dBm)
         * 2462 MHz [11] (20.0 dBm)
   Supported commands:
       * new_interface
       * set_interface
       * new_key
       * start_ap
       * join_ibss
       * set_pmksa
       * del_pmksa
       * flush_pmksa
       * remain_on_channel
       * frame
       * set_channel
       * start_sched_scan
       * start_p2p_device
       * crit_protocol_start
       * crit_protocol_stop
       * testmode
       * connect
       * disconnect
   Supported TX frame types:
       * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
       * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
       * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
       * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
   Supported RX frame types:
       * managed: 0x40 0xd0
       * P2P-client: 0x40 0xd0
       * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
       * P2P-device: 0x40 0xd0
   software interface modes (can always be added):
   valid interface combinations:
       * #{ IBSS, managed, AP } <= 2, #{ P2P-client, P2P-GO } <= 1, #{ P2P-device } <= 1,
         total <= 3, #channels <= 2
   Device supports scan flush.


I'm trying out with the following hostapd.conf:
Code: Select all
# cat hostapd.conf
ssid=AP
interface=wlan0
channel=7
driver=nl80211


And I get the error "wlan0: Could not connect to kernel driver"
Code: Select all
# hostapd -dd hostapd.conf
random: Trying to read entropy from /dev/random
Configuration file: hostapd.conf
nl80211: Could not add multicast membership for vendor events: -2 (No such file or directory)
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
rfkill: initial event: idx=1 type=2 op=0 soft=0 hard=0
rfkill: initial event: idx=2 type=1 op=0 soft=0 hard=0
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:6
nl80211: Using driver-based off-channel TX
nl80211: Use separate P2P group interface (driver advertised support)
nl80211: Enable multi-channel concurrent (driver advertised support)
nl80211: interface wlan0 in phy phy0
nl80211: Set mode ifindex 7 iftype 3 (AP)
nl80211: Setup AP(wlan0) - device_ap_sme=0 use_monitor=1
nl80211: Create interface iftype 6 (MONITOR)
Failed to create interface mon.wlan0: -95 (Operation not supported)
nl80211: Driver does not support monitor interface type - try to run without it
nl80211: Enable Probe Request reporting nl_preq=0xa05b0
nl80211: Register frame type=0x40 nl_handle=0xa05b0 match=
nl80211: Register frame command failed (type=64): ret=-22 (Invalid argument)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Failed to enable Probe Request frame reporting in AP mode
nl80211: Add own interface ifindex 7
nl80211: Do not indicate P2P_DEVICE support (p2p_device=1 driver param not specified)
phy: phy0
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
nl80211: Regulatory information - country=00
nl80211: 2402-2472 @ 40 MHz 20 mBm
nl80211: 2457-2482 @ 40 MHz 20 mBm
nl80211: 2474-2494 @ 20 MHz 20 mBm
nl80211: 5170-5250 @ 80 MHz 20 mBm
nl80211: 5735-5835 @ 80 MHz 20 mBm
nl80211: 57240-63720 @ 2160 MHz 0 mBm
nl80211: Added 802.11b mode based on 802.11g information
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=20 dBm
Completing interface initialization
Mode: IEEE 802.11b  Channel: 7  Frequency: 2442 MHz
DFS 0 channels required radar detection
nl80211: Set freq 2442 (ht_enabled=0, vht_enabled=0, bandwidth=20 MHz, cf1=2442 MHz, cf2=0 MHz)
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x0
RATE[3] rate=110 flags=0x0
hostapd_setup_bss(hapd=0x9ff48 (wlan0), first=1)
wlan0: Flushing old station entries
nl80211: flush -> DEL_STATION wlan0 (all)
nl80211: Station flush failed: ret=-14 (Bad address)
wlan0: Could not connect to kernel driver
wlan0: Deauthenticate all stations
nl80211: sta_remove -> DEL_STATION wlan0 ff:ff:ff:ff:ff:ff --> 0 (Success)
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
Using interface wlan0 with hwaddr 40:2c:f4:ae:1b:9e and ssid "AP"
nl80211: Set beacon (beacon_set=0)
nl80211: Beacon head - hexdump(len=49): 80 00 00 00 ff ff ff ff ff ff 40 2c f4 ae 1b 9e 40 2c f4 ae 1b 9e 00 00 00 00 00 00 00 00 00 00 64 00 01 00 00 02 41 50 01 04 82 84 0b 16 03 01 07
nl80211: Beacon tail - hexdump(len=0):
nl80211: ifindex=7
nl80211: beacon_int=100
nl80211: dtim_period=2
nl80211: ssid - hexdump_ascii(len=2):
     41 50                                             AP             
nl80211: hidden SSID not in use
nl80211: privacy=0
nl80211: auth_algs=0x3
nl80211: wpa_version=0x0
nl80211: key_mgmt_suites=0x2
nl80211: pairwise_ciphers=0x1
nl80211: group_cipher=0x1
nl80211: Beacon set failed: -6 (No such device or address)
Failed to set beacon parameters
wlan0: Unable to setup interface.
hostapd_interface_deinit_free(0x9f430)
hostapd_interface_deinit_free: num_bss=1 conf->num_bss=1
hostapd_interface_deinit(0x9f430)
hostapd_bss_deinit: deinit bss wlan0
wlan0: Flushing old station entries
nl80211: flush -> DEL_STATION wlan0 (all)
nl80211: Station flush failed: ret=-14 (Bad address)
wlan0: Could not connect to kernel driver
wlan0: Deauthenticate all stations
nl80211: sta_remove -> DEL_STATION wlan0 ff:ff:ff:ff:ff:ff --> 0 (Success)
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=7 (wlan0) alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
hostapd_cleanup(hapd=0x9ff48 (wlan0))
hostapd_free_hapd_data(wlan0)
hostapd_interface_deinit_free: driver=0x811d0 drv_priv=0xa0818 -> hapd_deinit
nl80211: Remove monitor interface: refcount=0
nl80211: Remove beacon (ifindex=7)
netlink: Operstate: ifindex=7 linkmode=0 (kernel-control), operstate=6 (IF_OPER_UP)
nl80211: Set mode ifindex 7 iftype 2 (STATION)
nl80211: Teardown AP(wlan0) - device_ap_sme=1 use_monitor=1
hostapd_interface_free(0x9f430)
hostapd_interface_free: free hapd 0x9ff48
hostapd_cleanup_iface(0x9f430)
hostapd_cleanup_iface_partial(0x9f430)
hostapd_cleanup_iface: free iface=0x9f430


Any ideas what could be going wrong? Or what I should do to troubleshoot?

Thanks in advance!
graffitici
 
Posts: 7
Joined: Fri Apr 18, 2014 10:33 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Sat Apr 19, 2014 3:09 am

I found that there are two things that you need to make AP mode work. You need a new firmware file and hostapd version 2. You can find reference to the firmware file I used. Please review this thread for details.
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby setti » Sat Apr 19, 2014 10:55 am

JohnW wrote:I needed the following mix of software and firmware:
- Hostapd v2
- Kernel 3.10.17 (from the github)
- Firmware from here: https://android.googlesource.com/platfo ... e/bcm4329/
- nvram.txt file from the original Wandboard distributions

For the combinations I tested below to find the right mix, here is the legend:
origfw = Original Firmware given by Tapani in the Wandboard SDKs (also incidentally is the same firmware used in Yocto)
orignvram = Original nvram.txt file from the same
newfw = New firmware given by Tapani in this thread
newnvram = New nvram.txt file
reallynewfw = FW that I found in the internet (link above)


Hey John, which one of the 3 (fw_bcm4329.bin, fw_bcm4329_abg.bin, fw_bcm4329_apsta.bin) do you mean?
I used apsta, as the 'device-bcm.mk' showed something like AP mode is only working with this, but i only get 8Mbit measuring via iperf.
setti
 
Posts: 39
Joined: Fri Jan 10, 2014 6:15 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Mon Apr 21, 2014 2:40 pm

Hi there.

Sorry about that - good catch. I used fw_bcm4329_apsta.bin with hostapd 2.0 and the 3.10.17 kernel. I was able to see +20 Mbits to it between a Macbook Pro and the Wandboard Quad.

I'm building a Yocto recipe to automate this process as well.

John
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby JohnW » Tue Apr 22, 2014 5:08 am

Update - here is the git repository for a Yocto metadata layer to turn Wandboard Dual or Quad into an access point:

https://github.com/johnweber/meta-wandboard-ap

Instructions are in the README.

Enjoy!
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby hitechor » Mon May 26, 2014 1:14 pm

I'm using WandBoard Dual to develop our products, and need WIFI as AP function.

I have tried a lot of ways :
1, Ubuntu 12.04 from the website, no AP mode was supported.

2, Using http://www.project-insanity.org/blog/20 ... wandboard/
BCMDHD drivers, and point linux-kernel to 3.10.17 and 3.14.4, and got these errors.
Code: Select all
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c: In function '_dhd_sysioc_thread':
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c:1238:2: error: implicit declaration of function 'daemonize' [-Werror=implicit-function-declaration]
  DAEMONIZE("dhd_sysioc");
  ^
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c: In function 'dhd_watchdog_thread':
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c:1944:47: error: 'MAX_RT_PRIO' undeclared (first use in this function)
   param.sched_priority = (dhd_watchdog_prio < MAX_RT_PRIO)?
                                               ^
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c:1944:47: note: each undeclared identifier is reported only once for each function it appears in
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c: In function 'dhd_dpc_thread':
/home/imx6/Downloads/Driver_Release_4329/Driver_Release_4329/bcmdhd/dhd_linux.c:2040:42: error: 'MAX_RT_PRIO' undeclared (first use in this function)
   param.sched_priority = (dhd_dpc_prio < MAX_RT_PRIO)?dhd_dpc_prio:(MAX_RT_PRIO-1);


3, using yocto daisy, https://github.com/johnweber/meta-wandboard-ap
and got errors too.
Code: Select all
ERROR: ExpansionError during parsing /home/imx6/wb-daisy/sources/poky/meta/recipes-core/init-ifupdown/init-ifupdown_1.0.bb: Failure expanding variable do_fetch[file-checksums], expression was ${@bb.fetch.get_checksum_file_list(d)} which triggered exception MalformedUrl: The URL: 'interfaces-wlan0-ap' is invalid and cannot be interpreted


4, using http://eewiki.net/display/linuxonarm/Wa ... board-WiFi , ubuntu 14.4
and
Code: Select all
[    4.798229] brcmfmac: F1 signature read @0x18000000=0x9934329
[    4.799328] brcmfmac: brcmf_sdio_chip_drivestrengthinit: No SDIO Drive strength init done for chip 4329 rev 3 pmurev 6
[    5.058286] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Sep  2 2011 14:48:19 version 4.220.48
[    5.082280] brcmfmac: brcmf_fil_cmd_data: Failed err=-23
[    5.087654] brcmfmac: brcmf_fws_init: failed to set bdcv2 tlv signaling



I have check the talks before, so is there any way to make wandboard-dl as AP ?
hitechor
 
Posts: 6
Joined: Mon May 26, 2014 1:04 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Mon May 26, 2014 6:13 pm

hitechor wrote:3, using yocto daisy, https://github.com/johnweber/meta-wandboard-ap
and got errors too.
Code: Select all
ERROR: ExpansionError during parsing /home/imx6/wb-daisy/sources/poky/meta/recipes-core/init-ifupdown/init-ifupdown_1.0.bb: Failure expanding variable do_fetch[file-checksums], expression was ${@bb.fetch.get_checksum_file_list(d)} which triggered exception MalformedUrl: The URL: 'interfaces-wlan0-ap' is invalid and cannot be interpreted



This is strange. I'm using the same recipe with Yocto Daisy and not getting this error. However, something in my local.conf might be fixing it.
Code: Select all
CORE_IMAGE_EXTRA_INSTALL_append = " \
wpa-supplicant \
dropbear \
openssh-sftp-server \
hostap-daemon \
dhcp-server \
dhcp-server-config \
linux-firmware-bcm4329-ap \
"
PREFERRED_VERSION_hostap-daemon = "2.0"
"


hitechor wrote:4, using http://eewiki.net/display/linuxonarm/Wa ... board-WiFi , ubuntu 14.4
and
Code: Select all
[    4.798229] brcmfmac: F1 signature read @0x18000000=0x9934329
[    4.799328] brcmfmac: brcmf_sdio_chip_drivestrengthinit: No SDIO Drive strength init done for chip 4329 rev 3 pmurev 6
[    5.058286] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Sep  2 2011 14:48:19 version 4.220.48
[    5.082280] brcmfmac: brcmf_fil_cmd_data: Failed err=-23
[    5.087654] brcmfmac: brcmf_fws_init: failed to set bdcv2 tlv signaling



I have check the talks before, so is there any way to make wandboard-dl as AP ?


The above errors happen with normal working AP setups, so for now they are ugly but do not prevent the AP or WLAN interface from running.
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby hitechor » Tue May 27, 2014 12:51 am

for yocto method, added
Code: Select all
PREFERRED_VERSION_hostap-daemon = "2.0"

but got the same error.

For Ubuntu 14.04, set the hostapd.conf as contained in yocto image,
sudo hostapd -d /etc/hostapd/hostapd.conf
Code: Select all
random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
Line 55: DEPRECATED: 'dump_file' configuration variable is not used anymore
ctrl_interface_group=0
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
rfkill: initial event: idx=1 type=2 op=0 soft=0 hard=0
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:6
nl80211: Using driver-based off-channel TX
nl80211: Use separate P2P group interface (driver advertised support)
nl80211: Enable multi-channel concurrent (driver advertised support)
nl80211: interface wlan0 in phy phy0
nl80211: Set mode ifindex 3 iftype 3 (AP)
nl80211: Setup AP(wlan0) - device_ap_sme=0 use_monitor=1
nl80211: Create interface iftype 6 (MONITOR)
Failed to create interface mon.wlan0: -95 (Operation not supported)
nl80211: Driver does not support monitor interface type - try to run without it
nl80211: Enable Probe Request reporting nl_preq=0x123dd28
nl80211: Register frame type=0x40 nl_handle=0x123dd28 match=
nl80211: Register frame command failed (type=64): ret=-22 (Invalid argument)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Failed to enable Probe Request frame reporting in AP mode
nl80211: Add own interface ifindex 3
nl80211: Do not indicate P2P_DEVICE support (p2p_device=1 driver param not specified)
phy: phy0
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Previous country code 00, new country code US
Continue interface setup after channel list update
ctrl_iface not configured!
random: Got 15/20 bytes from /dev/random
random: Got 5/5 bytes from /dev/random
Channel list update timeout - try to continue anyway
nl80211: Regulatory information - country=00
nl80211: 2402-2472 @ 40 MHz 20 mBm
nl80211: 2457-2482 @ 40 MHz 20 mBm
nl80211: 2474-2494 @ 20 MHz 20 mBm
nl80211: 5170-5250 @ 160 MHz 20 mBm
nl80211: 5250-5330 @ 160 MHz 20 mBm
nl80211: 5490-5730 @ 160 MHz 20 mBm
nl80211: Added 802.11b mode based on 802.11g information
Completing interface initialization
Mode: IEEE 802.11g  Channel: 11  Frequency: 2462 MHz
DFS 0 channels required radar detection
nl80211: Set freq 2462 (ht_enabled=1, vht_enabled=0, bandwidth=20 MHz, cf1=2462 MHz, cf2=0 MHz)
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x1
RATE[3] rate=110 flags=0x1
RATE[4] rate=60 flags=0x0
RATE[5] rate=90 flags=0x0
RATE[6] rate=120 flags=0x0
RATE[7] rate=180 flags=0x0
RATE[8] rate=240 flags=0x0
RATE[9] rate=360 flags=0x0
RATE[10] rate=480 flags=0x0
RATE[11] rate=540 flags=0x0
hostapd_setup_bss(hapd=0x123fa20 (wlan0), first=1)
wlan0: Flushing old station entries
nl80211: flush -> DEL_STATION wlan0 (all)
nl80211: Station flush failed: ret=-14 (Bad address)
wlan0: Could not connect to kernel driver
wlan0: Deauthenticate all stations
nl80211: sta_remove -> DEL_STATION wlan0 ff:ff:ff:ff:ff:ff --> 0 (Success)
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
Using interface wlan0 with hwaddr 40:2c:f4:ae:1b:a3 and ssid "wandboard"
Deriving WPA PSK based on passphrase
SSID - hexdump_ascii(len=9):
     77 61 6e 64 62 6f 61 72 64                        wandboard       
PSK (ASCII passphrase) - hexdump_ascii(len=9): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
GMK - hexdump(len=32): [REMOVED]
Key Counter - hexdump(len=32): [REMOVED]
WPA: Delay group state machine start until Beacon frames have been configured
VLAN: vlan_set_name_type(name_type=2)
nl80211: Set beacon (beacon_set=0)
nl80211: Beacon head - hexdump(len=60): 80 00 00 00 ff ff ff ff ff ff 40 2c f4 ae 1b a3 40 2c f4 ae 1b a3 00 00 00 00 00 00 00 00 00 00 64 00 11 04 00 09 77 61 6e 64 62 6f 61 72 64 01 08 82 84 8b 96 0c 12 18 24 03 01 0b
nl80211: Beacon tail - hexdump(len=117): 07 06 55 53 20 01 0b 14 2a 01 04 32 04 30 48 60 6c 30 14 01 00 00 0f ac 04 01 00 00 0f ac 04 01 00 00 0f ac 02 0c 00 2d 1a 2c 00 1f ff 00 00 00 00 00 00 00 00 00 00 00 01 00 00 00 00 00 00 00 00 00 00 3d 16 0b 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 dd 18 00 50 f2 02 01 01 00 00 03 a4 00 00 27 a4 00 00 42 43 5e 00 62 32 2f 00
nl80211: ifindex=3
nl80211: beacon_int=100
nl80211: dtim_period=2
nl80211: ssid - hexdump_ascii(len=9):
     77 61 6e 64 62 6f 61 72 64                        wandboard       
nl80211: hidden SSID not in use
nl80211: privacy=1
nl80211: auth_algs=0x3
nl80211: wpa_version=0x2
nl80211: key_mgmt_suites=0x2
nl80211: pairwise_ciphers=0x10
nl80211: group_cipher=0x10
nl80211: Beacon set failed: -6 (No such device or address)
Failed to set beacon parameters


So still no future progress.
hitechor
 
Posts: 6
Joined: Mon May 26, 2014 1:04 pm

Re: wandboard quad wifi ap mode

Postby hitechor » Tue May 27, 2014 1:01 am

At the same time, kernel post :
Code: Select all
nl80211: ifindex=3                                                             
nl80211: beacon_int=100                                                         
nl80211: dtim_period=2                                                         
nl80211: ssid - hexdump_ascii(len=9):                                           
     77 61 6e 64 62 6f 61 72 64                        wandboard               
nl80211: hidden SSID not i2                                                     
nl80211: key_mgmt_suites=0x2                                                   
nl80211: pairwise_ciphers=0x10                                                 
nl80211: group_cipher=0x10                                                     
[  345.941590] brcmfmac: brcmf_fil_cmd_data: Failed err=-23                     
[  345.948174] brcmfmac: brcmf_fil_cmd_data: Failed err=-6                     
[  345.953504] brcmfmac: brcmf_cfg80211_start_ap: setting AP mode failed -6     
nl80211: Beacon set failed: -6 (No such device or address)                     
Failed to set beacon parameters 


So Beacon -6 error may caused by setting AP mode failed -6
hitechor
 
Posts: 6
Joined: Mon May 26, 2014 1:04 pm

Re: wandboard quad wifi ap mode

Postby hitechor » Tue May 27, 2014 1:07 am

Now I can set the AP mode
fw_bcm4329_abg.bin result :
Code: Select all
[   30.940369] brcmfmac: brcmf_fil_cmd_data: Failed err=-23                     
[   31.578502] brcmfmac: brcmf_fil_cmd_data: Failed err=-23                     
[   31.585803] brcmfmac: brcmf_fil_cmd_data: Failed err=-23                     
[   31.591143] brcmfmac: brcmf_construct_reginfo: get chanspecs error (-23)     
[   31.597949] brcmfmac: brcmf_update_wiphybands: brcmf_construct_reginfo failed
 (-23)                                                                         
[   31.605686] brcmfmac: brcmf_netdev_open: failed to bring up cfg80211         
SIOCSIFFLAGS: Input/output error                                         


fw_bcm4329_apsta.bin
work well now.

Thanks for your help!

Btw
1, would the link in 14.04 update ?
2, How would things chane when board update to ver C ?
hitechor
 
Posts: 6
Joined: Mon May 26, 2014 1:04 pm

PreviousNext

Return to Software - General

Who is online

Users browsing this forum: No registered users and 16 guests

cron