wandboard quad wifi ap mode

This is the place for software discussions not having a dedicated subforum

Re: wandboard quad wifi ap mode

Postby CruX » Fri Jan 31, 2014 9:58 am

Hey,

I set n enabled, but it seems like it doesn't work. Also 5ghz doesn't seem to work (at least not in ap mode - I have not tested client).

Cheers
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

Re: wandboard quad wifi ap mode

Postby Tapani » Mon Feb 03, 2014 2:34 am

The Wandboard bcm4329 does not support 5GHz band.

Crux! Good work with AP mode!

And please create new posts when you have successes like that, editing old posts does not seem to mark a post as "unread"... and hence the good stuff might pass by unnoticed.
Tapani
Site Admin
 
Posts: 701
Joined: Tue Aug 27, 2013 8:32 am

Re: wandboard quad wifi ap mode

Postby CruX » Mon Feb 03, 2014 11:47 am

I know about that double-post thing, but I really don't like doubleposting...

Anyhow, I just wrote a blogpost summarizing the "journey" to ap mode. You can read it here.

I'm glad that we got that working now :)

Cheers,
CruX
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Thu Mar 27, 2014 1:58 pm

Hi CruX,

I read your blog and am attempting to follow in your footsteps to get AP mode working on Wandboard for Yocto and 3.10.17 (with unmodified brcmfmac driver). It seems that the new firmware is necessary to enable AP node.

I'm able to see the Wandboard in a list of APs. So that's good. I've also been able to get connected if I disable authentication (open mode).

Here is the problem that is stopping me. When I attempt to connect using WPA2 (haven't tried just WPA), I get this output from hostapd (I'm using hostapd v1.0 as that is what is currently in Yocto):

Code: Select all
nl80211: Event message available                                               
nl80211: New station e4:98:d6:2c:58:ea                                         
nl80211: Assoc Req IEs - hexdump(len=22): 30 14 01 00 00 0f ac 04 01 00 00 0f ac
 04 01 00 00 0f ac 02 0c 00                                                   
Add randomness: count=1 entropy=0                                             
wlan0: STA e4:98:d6:2c:58:ea IEEE 802.11: associated                           
STA included RSN IE in (Re)AssocReq                                           
  New STA                                                                     
wlan0: STA e4:98:d6:2c:58:ea WPA: event 1 notification                         
wpa_driver_nl80211_set_key: ifindex=4 alg=0 addr=0x1026428 key_idx=0 set_tx=1 se
q_len=0 key_len=0                                                             
   addr=e4:98:d6:2c:58:ea                                                     
IEEE 802.1X: Ignore STA - 802.1X not enabled or forced for WPS                 
wlan0: STA e4:98:d6:2c:58:ea WPA: start authentication                         
WPA: e4:98:d6:2c:58:ea WPA_PTK entering state INITIALIZE                       
wpa_driver_nl80211_set_key: ifindex=4 alg=0 addr=0x1026428 key_idx=0 set_tx=1 se
q_len=0 key_len=0                                                             
   addr=e4:98:d6:2c:58:ea                                                     
wlan0: STA e4:98:d6:2c:58:ea IEEE 802.1X: unauthorizing port                   
Could not set station e4:98:d6:2c:58:ea flags for kernel driver (errno=11).   
WPA: e4:98:d6:2c:58:ea WPA_PTK_GROUP entering state IDLE                       
WPA: e4:98:d6:2c:58:ea WPA_PTK entering state AUTHENTICATION                   
WPA: e4:98:d6:2c:58:ea WPA_PTK entering state AUTHENTICATION2                 
WPA: Re-initialize GMK/Counter on first station                               
Get randomness: len=32 entropy=1                                               
GMK - hexdump(len=32): [REMOVED]                                               
Get randomness: len=32 entropy=0                                               
Key Counter - hexdump(len=32): [REMOVED]                                       
Get randomness: len=16 entropy=0                                               
GTK - hexdump(len=16): [REMOVED]                                               
wpa_driver_nl80211_set_key: ifindex=4 alg=3 addr=0x62694 key_idx=1 set_tx=1 seq_
len=0 key_len=16                                                               
   broadcast key                                                               
WPA: Assign ANonce - hexdump(len=32): 48 27 51 84 c2 c7 a8 e8 0a c9 e2 93 4f a6
ce 44 54 13 d5 aa 21 82 6f dc d3 b0 4a 5c 4c ad ea 3c                         
WPA: e4:98:d6:2c:58:ea WPA_PTK entering state INITPSK                         
WPA: e4:98:d6:2c:58:ea WPA_PTK entering state PTKSTART                         
wlan0: STA e4:98:d6:2c:58:ea WPA: sending 1/4 msg of 4-Way Handshake           
WPA: Send EAPOL(version=2 secure=0 mic=0 ack=1 install=0 pairwise=8 kde_len=0 ke
yidx=0 encr=0)                                                                 
nl80211: No monitor socket available for wpa_driver_nl80211_send_frame         
i802_send_eapol - packet len: 131 - failed: 11 (Resource temporarily unavailable
)           


It then repeats another three times (starting from the WPA: line) and then the authentication process dies.

I wondering if you saw this during your 'travels' in getting this to work on your end?

Thanks,
John
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby CruX » Thu Mar 27, 2014 2:21 pm

Hey John,

I saw your post on my blog, but have not replied so far :/

While I do not recall this specific error, I am pretty sure, that you will sadly not get it working with 3.10.17 brcmfmac.
If I recall correctly, the 3.10.17 driver had issues (== unstable connection) as soon as you put some real traffic on the interface (more than just icmp).
But still, I was able to authenticate with this version tough...

This is the config I am using at the moment (with the driver from 3.13.2 iirc).
Code: Select all
interface=wlan0
driver=nl80211
channel=8
ssid=WBQ Wifi

auth_algs=1
wpa=2
wpa_passphrase=qlimaxdefqondominator
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
rsn_pairwise=CCMP
macaddr_acl=0

country_code=DE
wmm_enabled=1
ieee80211d=1
ieee80211n=1
hw_mode=g


I hope this helps...


Cheers!
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Fri Mar 28, 2014 3:31 am

CruX,

This does help. Thanks a lot.

John
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby JohnW » Fri Mar 28, 2014 4:13 am

Hi CruX,

Actually - I do have one other question - what version of hostapd were you using? The default in Yocto is 1.0, but I suspect that many binary distributions would make use of a later version.

Thanks,
John
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby CruX » Fri Mar 28, 2014 11:25 am

Hey John,

my arch currently uses 2.1, but I think I have a 1.x lying somewhere...
I don't know about the config files, but I could give it a try...

Regards,
CruX
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

Re: wandboard quad wifi ap mode

Postby JohnW » Sat Mar 29, 2014 4:53 am

Thanks CruX.

I have some good news to report. I have seen myself, with my very eyes, AP mode working on kernel 3.10.17. I've run SSH, ping, and iperf traffic over it.

I needed the following mix of software and firmware:
- Hostapd v2
- Kernel 3.10.17 (from the github)
- Firmware from here: https://android.googlesource.com/platfo ... e/bcm4329/
- nvram.txt file from the original Wandboard distributions

I'm able to get about 20 Mbits/s between my macbook pro and the Wandboard. This is nice. The bad news is this firmware business, which is a pain in the a$$. I get different performance based on firmware/nvram file combination, and I can't seem to find a good performance combination that works in both AP and STA mode.

For the combinations I tested below to find the right mix, here is the legend:
origfw = Original Firmware given by Tapani in the Wandboard SDKs (also incidentally is the same firmware used in Yocto)
orignvram = Original nvram.txt file from the same
newfw = New firmware given by Tapani in this thread
newnvram = New nvram.txt file
reallynewfw = FW that I found in the internet (link above)

Here are the results:
origfw + orignvram only works in STA mode and gives good performance at about 20 Mbps.
newfw + orignvram, works in both STA mode and AP mode. STA mode gives good performance, AP mode is bad (about 2-3 Mbps)
reallynewfw + newnvram, works in AP mode but not STA mode, performance is about 7-8 Mbps
reallynewfw + orignvram, works in AP mode but not STA mode, performance is good, about 20 Mbps

I did not try to optimize the hostapd.conf file to give better performance (e.g. enabling 40 MHz channels, etc.). So we might see better numbers by doing that.

My intent is to build a Yocto recipe to automate this.

I'll also see if the brcm wireless maintainers are going to updating the linux-firmware repository with AP-enabled firmware any time soon. Without that, it's difficult to get a recipe to enable AP mode on Wandboard into the mainline Yocto layers, as we don't want to be distributing questionably-licensed binary files. But, I'm happy to throw up a github repository with it so that other people can use it.
JohnW
 
Posts: 86
Joined: Sat Sep 07, 2013 3:01 pm
Location: United States

Re: wandboard quad wifi ap mode

Postby CruX » Sat Mar 29, 2014 7:23 pm

Hey John,

thats great feedback! I did not think this would be possible :)

The data rates around 20Mbit/s sound familiar to me, I think thats pretty much what I had.
I'm also running 3.10 now and have not yet fooled aroud with AP mode, partly because the overall performance of the wandboard as a router (NATing between ethernet and wifi) wasn't that astonishing... But that may have changed since.

Gotta try that sometime :)

Cheers
CruX
 
Posts: 68
Joined: Sun Oct 27, 2013 1:29 pm

PreviousNext

Return to Software - General

Who is online

Users browsing this forum: No registered users and 4 guests