no analog audio by hdmi video

Discuss Android on the Wandboard, as well as app development for or on the Wandboard.

no analog audio by hdmi video

Postby apuokas » Mon Dec 15, 2014 8:21 am

hallo,
i used latest android 4.4.2 image from wandboard.org site. On my wandboard quad c1 i used hdmi output to conect with 7" 1024x600x24RGB touch display. But i have no audio over analog output and i need it. I thik that android provides audio over hdmi and analog audio is off. I think i should add something in uEnv.txt to set analog audio as defoult audio device, but i dont know what should i setting. please, help.
regards
apuokas
 
Posts: 8
Joined: Mon Dec 15, 2014 7:57 am

Re: no analog audio by hdmi video

Postby Richard » Tue Dec 16, 2014 6:48 am

Hello, apuokas:

If you insert the HDMI cable, the audio would output from HDMI by default in android.
Would you please try to install "soundabout" APP to switch audio output from HDMI to analog?
https://play.google.com/store/apps/deta ... x&hl=zh_TW
Copy and paste the link above to following website. Then you can download "soundabout" APK.
http://apps.evozi.com/apk-downloader/

Install this apk to wandboard android.
Then execute this APP.
Set "Media audio" as "Speaker".

Then, audio should switch to analog output.

BR,

Richard
Attachments
soundabount_screen.png
soundabount_screen.png (61.54 KiB) Viewed 1497 times
Richard
Site Admin
 
Posts: 136
Joined: Tue Dec 17, 2013 6:57 am

Re: no analog audio by hdmi video

Postby apuokas » Wed Dec 17, 2014 9:41 pm

hallo Richard,
thank you- its worked with youtube app. with xbmc i have no audio, but there seems to be another problem- there is no progress by playng mp3 files. i had no time to terst more, but ill do it. any suggestions about that problem?
best regards
apuokas
P.S.
after soundabout i had installed skype, xbmc and set in soundabout "phone call" to speakers too. After that was no sound over analog audio agaain. than i installed vlc and reinstalled soundabout. set media to speakers but did nothing with another settings. This worked. Maybe xbmc und skype have some conflicts? continue testing...
apuokas
 
Posts: 8
Joined: Mon Dec 15, 2014 7:57 am

Re: no analog audio by hdmi video

Postby apuokas » Sun Jan 04, 2015 8:42 pm

i noticed new trouble: when i play something from my nas with xbmc, after some time sound is off. i can push pause/play or select another file, but there is no progress in progress-barr. i exit xbmc and trying to play something with another player, for example something on sd card with vlc (progress-bar moving but no any sound too) or another player and i have no sound too. it seems that audio output is off hardware or driver site. reboot fixes it but just till next crash. my android is rooted. anny sugestions?
apuokas
 
Posts: 8
Joined: Mon Dec 15, 2014 7:57 am

Re: no analog audio by hdmi video

Postby 88tec » Sun Aug 16, 2015 8:31 pm

I have exactly the same problem. Using the latest release of Android Lollipop 5.0.2.
i set the default audio output device to analog audio out and input to mic-in. I can play or record with the default player and record apps preinstalled once. When I exit the app (either standard music app or audio recorder) and restart those two there will be no sound nor will the audio recorder detect anything on the MicIn. Strangely the audio player also shows no progress
What kind of problem is that?
88tec
 
Posts: 7
Joined: Fri Aug 14, 2015 7:55 am

Re: no analog audio by hdmi video

Postby Wig » Mon Aug 17, 2015 2:18 am

Hi 88tec:

if you're sure you have change the audio to the microphone and headphone already, you can click the bar for sound setting to heard the sound source when you exit the app, maybe your app change back hdmi-audio when the process was be killed!

Thank you!
Wig
 
Posts: 80
Joined: Mon Apr 20, 2015 7:20 am

Re: no analog audio by hdmi video

Postby 88tec » Thu Aug 20, 2015 9:04 am

the thing is I will not get sound via HDMI either after the mentioned procedure.
what I've found out so far is: playing & recording audio through analog LineOut/MicIN works fine until I pull the Headset out of LineOut
using ADB logcat to show system logs shows that after pulling out and plugging in again, the system somehow fails to init the audio device (as I mentioned above HDMI and any analog audio are deactivated)
88tec
 
Posts: 7
Joined: Fri Aug 14, 2015 7:55 am

Re: no analog audio by hdmi video

Postby stuartgray » Sat Mar 04, 2017 6:49 am

thanks for sharing Xmodgames app
stuartgray
 
Posts: 1
Joined: Sat Mar 04, 2017 6:48 am

Re: no analog audio by hdmi video

Postby stuartsmith » Sun Apr 09, 2017 8:30 am

usps tracking good post
stuartsmith
 
Posts: 1
Joined: Sun Apr 09, 2017 8:29 am


Return to Software - Android

Who is online

Users browsing this forum: No registered users and 4 guests