Linker issue when bitbaking fsl-image-multimedia with Daisy

Yocto related software discussions are here

Linker issue when bitbaking fsl-image-multimedia with Daisy

Postby onnimikki » Wed Aug 20, 2014 2:06 pm


I'm trying to bitbake fsl-image-multimedia-full on a Fedora 20 machine, using the Daisy branch of Yocto. I followed the instructions for the Yocto Daisy branch on The core-image-minimal built fine. I've set my machine to the quad version of the Wandboard and I''ve added DISTRO_FEATURES_remove = "x11 waylaid". When I bitbake fsl-image-multimedia I get the following error

Code: Select all
| /opt/pc/tests/fsl-community-bsp/build/tmp/sysroots/x86_64-linux/usr/libexec/cortexa9hf-vfp-neon-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.8.2/ld: cannot find -lXext
| collect2: error: ld returned 1 exit status
| make[1]: *** [] Error 1
| make[1]: Leaving directory `/opt/pc/tests/fsl-community-bsp/build/tmp/work/wandboard_quad-poky-linux-gnueabi/gst-fsl-plugin/3.0.11-r0/gst-fsl-plugins-3.0.11/src/misc/v4l_sink/src'
| make: *** [all-recursive] Error 1
| ERROR: oe_runmake failed
| WARNING: /opt/pc/tests/fsl-community-bsp/build/tmp/work/wandboard_quad-poky-linux-gnueabi/gst-fsl-plugin/3.0.11-r0/temp/run.do_compile.11872:1 exit 1 from
|   exit 1
| ERROR: Function failed: do_compile (log file is located at /opt/pc/tests/fsl-community-bsp/build/tmp/work/wandboard_quad-poky-linux-gnueabi/gst-fsl-plugin/3.0.11-r0/temp/log.do_compile.11872)
ERROR: Task 641 (/opt/pc/tests/fsl-community-bsp/sources/meta-fsl-arm/recipes-multimedia/gstreamer/, do_compile) failed with exit code '1'

The error log file is found here:

It appears that the linker is having trouble. Has anyone seen this before or know of a workaround?


Posts: 3
Joined: Thu Aug 14, 2014 12:44 pm

Return to Software - Yocto

Who is online

Users browsing this forum: Bing [Bot] and 9 guests