No compiler can produce code for this Qt version.

Yocto related software discussions are here

No compiler can produce code for this Qt version.

Postby archi » Mon Feb 24, 2014 8:49 pm

Hello everyone!
I have been trying to create a cross compiler for QT in my wandboard (using a Yocto core-minimal-image with QT5 on it).
I have followed this guide on building Qt5 using yocto on Wandboard.
I have also followed this guide on Setup QT creator for developing QT apps on wandboard.

When I try to add a Qt Version in the tools menu, I get an admiration (attention) sign and a message that sais "No compiler can produce code for this Qt version. Please define one or more compilers."

I have read a few threads more or less with this same error, but the solutions on them are not helping me at all.. :(
This is what I have used (first time):
bitbake meta-toolchain using dora branch
---> I installed poky-eglibc-x86_64-meta-toolchain-cortexa9hf-vfp-neon-toolchain-1.5.1.sh
qt-everzwhere-opensource-src-5.1.1.tar.gz
qt-creator-opensource-linux-x86-3.0.0.run
---> Based on Qt 5.2.0 (GCC 4.6.1, 32bit)

After I realized that the qt-creator I am using is based in Qt 5.2.0 I did everything again using:
bitbake meta-toolchain using dora branch
---> I installed poky-eglibc-x86_64-meta-toolchain-cortexa9hf-vfp-neon-toolchain-1.5.1.sh
qt-everzwhere-opensource-src-5.2.1.tar.gz

but this time, when I try to run ./configure..... to make the crosscompiler everything is apparently fine, so I run
"sudo make -j4"
And it turns out that there is not makefile to run make.

I am in the threshold where frustration becomes giving up, so if anyone could give a hit would be awesome!

Thanks in advace to all of you.

By the way, I am running on Ubuntu 12.04, and if I am missing any important information here, please let me know!

Thanks again!

Archi.
archi
 
Posts: 1
Joined: Fri Jan 24, 2014 5:40 pm

Re: No compiler can produce code for this Qt version.

Postby Richard » Thu Feb 27, 2014 8:04 am

Hello, Archi:

I didn't follow your step, so I didn't exactly know what's the problem you run into.
This problem shouldn't result from the version mismatch between QT creator and QT.
Because I also use qt-creator-opensource-linux-x86-3.0.0.run to connect to yocto with QT 5.1.1.
"Qt version" checks many environment variables in qmake(qmake has many information about environment path).
And QT is built in Yocto environment, so many QT related environment variables need to export to let Qt creator knows.
That's why the guide in wiki add qmake variables to qtcreator.sh.
Richard
Site Admin
 
Posts: 139
Joined: Tue Dec 17, 2013 6:57 am

Re: No compiler can produce code for this Qt version.

Postby Jay » Sun May 04, 2014 8:50 am

Hi,
I get exactly same error following this wiki http://wiki.wandboard.org/index.php/Building_Qt5_using_yocto_on_Wandboard

pls find the screenshot .

Any help here is appreciated.
Attachments
snapshot1.jpeg
snapshot1.jpeg (137.44 KiB) Viewed 4269 times
Jay
 
Posts: 1
Joined: Sun May 04, 2014 8:32 am

Re: No compiler can produce code for this Qt version.

Postby xinxu2000 » Mon Jun 16, 2014 2:20 pm

I am facing the same problem following the instructions from:

http://wiki.wandboard.org/index.php/Bui ... _Wandboard
and
http://wiki.wandboard.org/index.php/Set ... _wandboard

has anyone find out what the problem is? understand that it is caused by mismatch of qtcreator.sh and the qmake I created. how can I look into qmake?
xinxu2000
 
Posts: 1
Joined: Mon Jun 16, 2014 2:04 pm


Return to Software - Yocto

Who is online

Users browsing this forum: No registered users and 2 guests