imx7d and hotspot mode

Yocto related software discussions are here

imx7d and hotspot mode

Postby Maash » Tue Dec 12, 2017 1:37 pm

Hi.


I'm trying to put the imx7d board into hotspot mode. I've got the broadcom driver loaded (bcmdhd.ko) and it works just fine in client mode.

However when I try to put the module into hotspot it appears as one, however I cannot get it to give IP address for the connected device.

I put it into hotspot like this is shell script:
Code: Select all
    rfkill unblock wlan
    killall wpa_supplicant
    killall udhcpc
    echo 2 > /sys/module/bcmdhd/parameters/op_mode
    udhcpd /etc/udhcpd.conf
    hostapd /etc/hostapd.conf &


terminal output:
Received SIGTERM
Code: Select all
_dhd_wlfc_mac_entry_update():1649, entry(32)
CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
Using interface wlan0 with hwaddr b0:f1:ec:ff:9a:93 and ssid "TestWifi"
random: Only 15/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operaCFG80211-ERROR) wl_cfg80211_set_channel : tions - update keys later when
 thnetdev_ifidx(6), chan_type(1) target channel(7)
e first station connects
CFG80211-ERROR) wl_cfg80211_parse_ies : No WPSIE in beacon
CFG80211-ERROR) wl_cfg80211_parse_ies : No WPSIE in beacon
_dhd_wlfc_mac_entry_update():1649, entry(32)
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED


The connection attempt causes this log:
Code: Select all
wlan0: STA cc:9f:7a:da:ed:4a IEEE 802.11: associated
wlan0: AP-STA-CONNECTED cc:9f:7a:da:ed:4a
wlan0: STA cc:9f:7a:da:ed:4a RADIUS: starting accounting session 302F8BC1-00000001
wlan0: STA cc:9f:7a:da:ed:4a WPA: pairwise key handshake completed (RSN)
CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH_IND(6) status 0 reason 3
wlan0: STA cc:9f:7a:da:ed:4a IEEE 802.11: disassociated
wlan0: ACFG80211-ERROR) wl_cfg80211_del_station : P-STA-DISCONNECTED cc:9f:7a:da:ed
Disconnect STA : cc:9f:7a:da:ed:4a scb_val.val 3:4a



my udhcpd.conf:
Code: Select all
# Sample udhcpd configuration file (/etc/udhcpd.conf)
# The start and end of the IP lease block
start 192.168.0.2
end 192.168.0.20
# The interface that udhcpd will use
interface      wlan0
#default: eth0
#Examles
opt     lease   864000


my /etc/network/interfaces:
Code: Select all
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
 
# The loopback interface
auto lo
iface lo inet loopback

# Wireless interfaces
auto wlan0
#allow-hotplug wlan0
iface wlan0 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0

iface atml0 inet dhcp

# Wired or wireless interfaces
auto eth0
iface eth0 inet dhcp
iface eth1 inet dhcp

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
iface usb0 inet static
        address 192.168.7.2
        netmask 255.255.255.0
        network 192.168.7.0
        gateway 192.168.7.1

# Bluetooth networking
iface bnep0 inet dhcp



my /etc/hostadp.conf:
Code: Select all
interface=wlan0
driver=nl80211
ssid=TestWifi
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=OhSoSecrectPW
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP


About my sw:
hostadp version: v2.5
udhcpcd version: v1.24.1

Yocto: yocto 2.0 Jethro (Technexion repo: https://github.com/TechNexion/edm-yocto ... GA?files=1)
Maash
 
Posts: 3
Joined: Tue Dec 12, 2017 12:11 pm

Re: imx7d and hotspot mode

Postby Maash » Wed Dec 13, 2017 10:01 am

Ok, it was embarracing problem. I didn't actually turn on the udhcpd :(.
Maash
 
Posts: 3
Joined: Tue Dec 12, 2017 12:11 pm

Re: imx7d and hotspot mode

Postby ClayMontgomery » Sun Dec 24, 2017 4:02 pm

Thanks for sharing this. It is interesting information!
ClayMontgomery
 
Posts: 96
Joined: Tue Nov 19, 2013 9:14 pm


Return to Software - Yocto

Who is online

Users browsing this forum: No registered users and 7 guests

cron