Trouble building dizzy QT5 image

Yocto related software discussions are here

Trouble building dizzy QT5 image

Postby klove » Mon Dec 04, 2017 12:11 am

Hello all,
I'm trying to get some basic development images built for a Wandboard Solo. I'm new to Yocto, so please forgive me if I'm missing something obvious.

My build platform is Ubuntu 14.04.

I have followed the instructions here to build the core-minimal image: ... _Wandboard
No issues here, this builds without errors and seems to boot fine on the Wandboard.

Next, I am attempting to build a QT5 image, per the instructions here: ... _Wandboard
This is where the wheels are coming off, I can't get an error-free build.

I can certainly dive into the errors I'm seeing, but first I wanted to ask some questions about the Build Configuration I'm seeing, see below:
Build Configuration:
BB_VERSION = "1.24.0"
BUILD_SYS = "i686-linux"
NATIVELSBSTRING = "Ubuntu-14.04"
TARGET_SYS = "arm-poky-linux-gnueabi"
MACHINE = "wandboard-solo"
DISTRO = "poky"
TUNE_FEATURES = "arm armv7a vfp neon callconvention-hard cortexa9"
TARGET_FPU = "vfp-neon"
meta-yocto = "(nobranch):fb8bf6a75e9ac04d5c6213d3e2f097302f83405f"
meta-multimedia = "(nobranch):70beecb2716bca1b9dfbc7d6a264233e1f05e82b"
meta-fsl-arm = "(nobranch):8f2651c0a38674d41ba7d30fa444762ef64f26b9"
meta-fsl-arm-extra = "(nobranch):794e46e0b0a3e7e270a2f3c217d8fe5751a6b2c6"
meta-fsl-demos = "(nobranch):1238a5709cb0940dd6437f3199de46879b6c2c51"
meta-qt5 = "dizzy:adeca0db212d61a933d7952ad44ea1064cfca747"
meta-ruby = "(nobranch):70beecb2716bca1b9dfbc7d6a264233e1f05e82b"

Notice that the meta-qt5 layer shows the 'dizzy' branch. This layer was added using the ' git clone -b dizzy' command per the instructions referenced above.
The other layers were added from the original 'Getting Started' walk-through using the 'repo' script contained there. I ran that script using the '-b dizzy' command line option.

Why do those original layers show '(nobranch)' instead of 'dizzy', like the QT5 layer? Are my issues because of a branch mis-match between the QT5 layer and everything else? If so, I would appreciate any pointers on how to start the debugging process.

Posts: 2
Joined: Sun Dec 03, 2017 11:52 pm

Re: Trouble building dizzy QT5 image

Postby klove » Tue Dec 05, 2017 4:55 am

So now I'm trying to address the individual errors in this build.

After taking care of an invalid object file, I now have the following issue:

/home/kirk/fsl-community-bsp/build/tmp/sysroots/i686-linux/usr/libexec/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.9.1/ld: cannot find -lXext

The libxext-dev library is installed on the build machine, I'm assuming that is the one it needs? Obviously I need to point the linker to that library. Any pointers on how to do this with Yocto?

Posts: 2
Joined: Sun Dec 03, 2017 11:52 pm

Re: Trouble building dizzy QT5 image

Postby ClayMontgomery » Thu Mar 01, 2018 3:46 pm


It is not sufficient for the libxext-dev library to be installed on the build machine, because bitbake must be able to cross-compile that library for your target image.
You need to create a new bitbake recipe for that library and add it to the 'sources' for Yocto. I'm assuming you don't already have one.

Also, I recommend you use either Fido or Pyro (if you need 4.1 kernel). Dizzy is really old.

Regards, Clay
Posts: 76
Joined: Tue Nov 19, 2013 9:14 pm

Return to Software - Yocto

Who is online

Users browsing this forum: Bing [Bot] and 14 guests