QT Creator + Wandboard

Yocto related software discussions are here

Re: QT Creator + Wandboard

Postby lprocha » Tue Nov 04, 2014 11:53 am

HI , i already follow all the steps and i could compile and run some aplications in my wandboard quad , but now when i try to use some features like QtQuick.Controls 1.2,QtQuick.Controls.Private 1.0, QtQuick.Controls.Styles 1.1 in the QML i[m getting a error.
i donr know if the recepts i use to get the sdk need to be changed or th problem is in the Yocto i generate to my wandboard , i use the core-image-minimal and meta-toolchain-qt5 to the sdk .

Does enybody knows where could be the problem ? and how to solve it ?

Thanks

Lucas
lprocha
 
Posts: 10
Joined: Wed Mar 12, 2014 8:44 pm

Re: QT Creator + Wandboard

Postby lprocha » Thu Nov 06, 2014 10:40 am

Dear all, during the bitbake process am getting an error below

Computing transaction...error: Can't install packagegroup-qt5-toolchain-target-1.0-r0@all: no package provides qtquickcontrols-qmlplugins


ERROR: Task 7 (/home/lucas/opt/labs/ex/fsl-community-bsp/sources/meta-qt5/recipes-qt/meta/meta-toolchain-qt5.bb, do_populate_sdk) failed with exit code '1'


Does anybody knows how to fix it and generate the sdk

Thanks
lprocha
 
Posts: 10
Joined: Wed Mar 12, 2014 8:44 pm

Re: QT Creator + Wandboard

Postby lprocha » Wed Nov 26, 2014 5:21 pm

He Guys , im trying to build a yocto 1.7 whit qt 5.3.2 , all the compilation process are OK , i got the images but when i try to run any aplication i[m getting the error below .

./Qt5_CinematicExperience -platform eglfs
QEglFSImx6Hooks will set environment variable FB_MULTI_BUFFER=2 to enable double buffering and vsync.
If this is not desired, you can override this via: export QT_EGLFS_IMX6_NO_FB_MULTI_BUFFER=1
mxc_sdc_fb fb.26: 800x480 h_sync,r,l: 10,164,89 v_sync,l,u: 10,10,23 pixclock=33500000 Hz
Segmentation fault

Does anybody know the reason for this and how to solve it

Thanks

Lucas Prado Rocha
lprocha
 
Posts: 10
Joined: Wed Mar 12, 2014 8:44 pm

Re: QT Creator + Wandboard

Postby ronk » Mon Jun 29, 2015 3:28 am

I followed the instructions given at http://wiki.wandboard.org/index.php/Bui ... _Wandboard.
I included the 'DISTRO_FEATURES_remove = "X11 wayland" ' line in
the builds completed successfully, I was able to copy the output to the sdcard and boot the Wandboard solo successfully. The message "auto-detected panel HDMI" appeared at the uBoot startup.

I would like to use this build with a monitor on the HDMI port.

I logged in as root and attempted to "Test the image" with 'Qt5_CinematicExperience -platform eglfs', but get the following output on the serial terminal:
mxc_sdc_fb fb.26: 1280x720 h_sync,r,l: 40,110,220 v_sync,l,u: 5,5,20 pixclock=74250000 Hz
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile

The HDMI monitor remains black.

Any help in getting this operational would be most appreciated.
ronk
 
Posts: 1
Joined: Mon Jun 29, 2015 3:05 am

Re: QT Creator + Wandboard

Postby Richard » Wed Feb 01, 2017 3:15 pm

Hello, ronk:

From the reference link you gave, there is a note - "The Wandboard Linux Kernel 3.10.17 comes configured with 24 bit depth for HDMI and LCD displays in the device tree. If you experience problems running Qt5 applications with the eglfs platform, change the bit depth to 32 bits in your own kernel fork or use the fbset (fbset [w] [h] [w] [h] 32) BEFORE running any egl application."

Changing the color depth may be a workaround.

BTW, "strace" is useful to figure out if there is problem when executing this application.

BR,

Richard
Richard
Site Admin
 
Posts: 134
Joined: Tue Dec 17, 2013 6:57 am

Previous

Return to Software - Yocto

Who is online

Users browsing this forum: No registered users and 4 guests

cron