Page 1 of 1

Compiling QT with Sato Image

PostPosted: Mon Sep 04, 2017 10:42 am
by deepteriar
Hi All,

I have successfully built sato and qt5 image respectively using http://www.jumpnowtek.com/wandboard/Wan ... Yocto.html
Currently I am using jethro branch. Now I need to integrate the qt5 libraries with sato image.
I followed http://wiki.wandboard.org/Integrate_Qt5 ... _Wandboard but it this is not working for jethro branch.
I am not able to get the desktop.
Can anyone please let me know.

Thanks

Re: Compiling QT with Sato Image

PostPosted: Thu Sep 07, 2017 3:03 pm
by ClayMontgomery
If you successfully built a sato and qt5 image, the qt libraries should already be integrated into the filesystem in that image.

The instructions you referenced are for a much older version of Yocto, 1.5. You probably need to go back at least to Fido (Yocto 1.8). The newer Yocto releases are not well tested on the i.MX6.

Regards, Clay

Re: Compiling QT with Sato Image

PostPosted: Mon Sep 11, 2017 10:04 am
by deepteriar
Hi Clay,

I have separately built both qt and sato image. How to copy all the qt libraries in sato image.Can you please give the instruction for fido branch.
I am getting the error "Cannot find Xcb display"


Thanks

Re: Compiling QT with Sato Image

PostPosted: Mon Sep 11, 2017 3:46 pm
by ClayMontgomery
I think that error message means that X11 is not installed and Qt requires X11.

The correct build command depends on the Yocto version, but I would use Fido:

bitbake fsl-image-qt5

Did you edit this yocto configuration file?

Edit "build/conf/local.conf" to add opengl and x11 to "DISTRO_FEATURES_append":

DISTRO_FEATURES_append = " opengl x11"

Regards, Clay