SD Card WiFi Driver Fails on wandboard with "warrrior"

Yocto related software discussions are here

SD Card WiFi Driver Fails on wandboard with "warrrior"

Postby GregTahoe » Wed Sep 18, 2019 10:54 pm

I am trying to build a Yocto based image for the wandboard with the WB-EDM-iMX6 REV C1 board installed to work with an SD Card based Wi-Fi Module - BCM43340

I am using the repo initialization: repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b warrior along with repo sync.

There is not a wandboard-quad supported by this BSP so I then initialize the build with the following:

MACHINE=wandboard DISTRO=poky source setup-environment build

I have modified the local.conf to be as follows

MACHINE ??= 'wandboard'
DISTRO ?= 'poky'
PACKAGE_CLASSES ?= 'package_rpm'
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"
DISTRO_FEATURES += "wifi"
BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
CORE_IMAGE_EXTRA_INSTALL += "openssh"
CONF_VERSION = "1"

DL_DIR ?= "${BSPDIR}/downloads/"
ACCEPT_FSL_EULA = "1"


I use the following bitbake build

bitbake core-image-base

The onboard Wi-Fi module and driver are active and I can do a scan with it so the Wi-Fi Tools are working correctly

When I plug the SD Card unit into the SD Card Slot I get the following

[ 70.269200] mmc0: new high speed SDIO card at address 0001
[ 70.282706] brcmfmac: brcmf_chip_cores_check: CPU core not detected
[ 70.289090] brcmfmac: brcmf_sdio_probe_attach: brcmf_chip_attach failed!
[ 70.295878] brcmfmac: brcmf_sdio_probe: brcmf_sdio_probe_attach failed
[ 70.304000] brcmfmac: brcmf_ops_sdio_probe: F2 error, probe failed -19...


I am expecting to have a wlan1 available after the driver loads.

Can you provide some insight into what may be missing?

Do I need to modify the Device Tree to accept this board in the SD Card Slot?

Thanks
GregTahoe
 
Posts: 3
Joined: Tue Sep 17, 2019 3:17 pm

Return to Software - Yocto

Who is online

Users browsing this forum: No registered users and 3 guests